Bug 427177 - s-c-date traceback when zooming while GMT[+/-x] zone selected
s-c-date traceback when zooming while GMT[+/-x] zone selected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
9
athlon Linux
low Severity low
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On: 293241
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 19:20 EST by David Timms
Modified: 2009-03-13 18:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 490232 (view as bug list)
Environment:
Last Closed: 2009-03-13 18:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Timms 2008-01-01 19:20:18 EST
+++ This bug was initially created as a clone of Bug #293241 +++

Description of problem:
Traceback possibly because trying to zoom to a non-existent point ?

Version-Release number of selected component (if applicable):
system-config-date-1.9.18-1.fc9

Steps to Reproduce:
1. start system-config-date from gnome-terminal
2. Time Zone tab
3. scroll to bottom of selected city pane
4. expand non-geographic-timezones
5. choose any of the GMT options.
6. adjust the zoom level of the map
  
Actual results:
1. Nothing seems to happen in the map
2. A traceback appears on the terminal:

Traceback (most recent call last):
  File "/usr/share/system-config-date/timezone_map_gui.py", line 139, in
zoom_value_changed_cb
    self.zoom_set (self.zoomAdjustment.get_value ())
  File "/usr/share/system-config-date/timezone_map_gui.py", line 378, in zoom_set
    self.currentCityText_set ()
  File "/usr/share/system-config-date/timezone_map_gui.py", line 277, in
currentCityText_set
    x, y = self.map2canvas (e.lat, e.long)
  File "/usr/share/system-config-date/timezone_map_gui.py", line 631, in map2canvas
    x = x2 / 2.0 + (x2 / 2.0) * long / 180.0
TypeError: unsupported operand type(s) for *: 'float' and 'NoneType'

Info:
I propose a simple way around this might be to assign a lat/long to each of the
GMT zones of 15x{GMT zone}degE:0degN.
Additionally place those positions around the equator on the map.
If you think this would be suitable, let me know and I'll take a deeper look.

If you think that it would be better to highlight N-S bands around the map, and
you think that is possible with the current widgets etc, I wouldn't mind taking
a look.
Comment 1 Bug Zapper 2008-05-14 00:16:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 lexual 2009-02-26 18:55:57 EST
system-config-date-1.9.34-1.fc10.noarch from Fedora 10.

I can't reproduce here.

Does this happen everytime?
Does this happen with latest updates?
Comment 3 David Timms 2009-03-01 07:16:24 EST
(In reply to comment #2)
> system-config-date-1.9.34-1.fc10.noarch from Fedora 10.
> 
> I can't reproduce here.
> 
> Does this happen everytime?
On F9 with the version indicated, yes.

> Does this happen with latest updates?
system-config-date-1.9.34-1.fc10.noarch: 

Item (1) is still an issue - selecting eg gmt+10 etc doesn't centre the map to the longitude that this represents. Instead,when the map is zoomed in, the centre stays near abidjan, africa (probably on the equator).

(2) is no longer occurring on F10 i386 nor x86_64, not sure if by accident or design.

I could split the bug into an rfe for part 1, and close the part 2 traceback part (this), if that would make sense ?
Comment 4 lexual 2009-03-01 07:56:46 EST
Looks like F9 has more recent version that you've indicated.
Have you tried that version?
Comment 5 David Timms 2009-03-13 18:25:32 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > system-config-date-1.9.34-1.fc10.noarch from Fedora 10.
> > Does this happen everytime?
> On F9 with the version indicated, yes.
As expected, issue (2) is also resolved in current system-config-date-1.9.36-1.fc9.noarch

Issue (1) is still occurring, do you concur ?

> I could split the bug into an rfe for part 1, and close the part 2 traceback
> part (this), if that would make sense ?  
?

Otherwise, I can change the description to "Selecting a UTC timezone does not centre the world map" ?
Comment 6 David Timms 2009-03-13 18:51:44 EDT
Cloned bug to new bug 490232 to track the lack of map scrolling.

Closing this bug as the traceback is resolved in current versions, including:
system-config-date-1.9.36-1.fc11.noarch

Note You need to log in before you can comment on or make changes to this bug.