This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 427181 - bind tool host interprets search order without leading dot
bind tool host interprets search order without leading dot
Status: CLOSED DUPLICATE of bug 426348
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 21:11 EST by David Carlson
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 06:45:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Carlson 2008-01-01 21:11:13 EST
Description of problem:

host is querying "compyexample.com" instead of "compy.example.com" when you run
'host compy' with an example.com search domain

Version-Release number of selected component (if applicable):

bind-utils-9.5.0-20.b1.fc8

How reproducible:

Steps to Reproduce:
1. Have a domain in your search order
2. Run host against a known short name in your domain
3. Miserable Failure
  
Actual results:

[thecubic@hades ~]$ host mars
Host mars not found: 3(NXDOMAIN)

[thecubic@hades ~]$ ping mars
PING mars.thecubic.net (192.168.6.11) 56(84) bytes of data.
64 bytes from 192.168.6.11: icmp_seq=2 ttl=64 time=5.30 ms

[thecubic@hades ~]$ host -v mars
Trying "marsthecubic.net"
Trying "mars"
Host mars not found: 3(NXDOMAIN)
Received 97 bytes from 192.168.6.1#53 in 1 ms

[thecubic@hades ~]$ host mars.
mars.thecubic.net has address 192.168.6.11
mars.thecubic.net has IPv6 address 2002:1876:9a5d:ecbc:20e:35ff:fe3f:8295

Expected results (as worked on Fedora 7):

[thecubic@hades ~]$ host mars
mars.thecubic.net has address 192.168.6.11
mars.thecubic.net has IPv6 address 2002:1876:9a5d:ecbc:20e:35ff:fe3f:8295

Additional info:

This worked on Fedora 7
Comment 1 Adam Tkac 2008-01-02 06:45:25 EST

*** This bug has been marked as a duplicate of 426348 ***

Note You need to log in before you can comment on or make changes to this bug.