Bug 42722 - gmc doesn't allow user to disable checking for new devices on startup
gmc doesn't allow user to disable checking for new devices on startup
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gmc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 13:45 EDT by Manfred Hollstein
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 13:57:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2001-05-29 13:45:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When gmc  is started after  logging in, it  rescans /etc/fstab for new
devices which may  have been added  due to new "kudzu" entries.  While
this  sounds  reasonable,  it  is annoying for those who don't want to
have any device symbols on their desktop, like myself. It is even more
annoying since,  when you have several "noauto" NFS entries,  creation
of symbolic links for the top-level of  those NFS mount points somehow
fails, resulting  in error dialog boxes, which  one  has to click away
one   after  the other...  Then  I'm usually   selecting all generated
symbols on the desktop and remove them, just to get the same behaviour
after the next login :-(

How reproducible:
Always

Steps to Reproduce:
1.Login using GNOME
2.Remove all device symbols from the desktop
3.Logout saving changes
4.Login again and all device symbols will be there again, too :-(


Actual Results:  See under description.

Expected Results:  There should be a configuration item, e.g. provided by
the
"Desktop Properties" dialog allowing me to toggle automatic creation
of such device symbols.


Additional info:

I rebuilt the original 7.1 mc-4.5.51-32.src.rpm with the following
patch applied; this fixes the problem for me. If the patch doesn't
apply for you due to whitespace/formatting problems, it is available
here <http://www.cygnus.com/~manfredh/rhl7.1/mc-4.5.51-32.mh1.patch>
as well.


diff -up SPECS/mc.spec.orig SPECS/mc.spec
--- SPECS/mc.spec.orig  Mon Apr  2 16:14:21 2001
+++ SPECS/mc.spec       Tue May 29 15:29:40 2001
@@ -1,7 +1,7 @@
 Summary: A user-friendly file manager and visual shell.
 Name:          mc
 Version:       4.5.51
-Release:       32
+Release:       32.mh1
 Copyright:     GPL
 Group:         System Environment/Shells
 Source0:      
ftp://ftp.gnome.org/pub/GNOME/sources/mc/mc-%{version}.tar.gz
@@ -42,6 +42,7 @@ Patch41:   mc-4.5.51-kudzu.patch
 Patch42:   mc-4.5.51-troff.patch
 Patch43:   mc-4.5.51-initialdevices.patch
 Patch44:   gmc-4.5.51-mountfix.patch
+Patch45:   gmc-4.5.51-desktopicons.patch
 
 %description
 Midnight Commander is a visual shell much like a file manager, only
@@ -104,6 +105,7 @@ popd
 %patch42 -p1 -b .troff
 %patch43 -p1 -b .initialdevices
 %patch44 -p1 -b .mountfix
+%patch45 -p1 -b .desktopicons
 
 cp %{SOURCE10} po/ja.po
 
@@ -205,6 +207,9 @@ fi
 %config /usr/lib/desktop-links/*
 
 %changelog
+* Tue May 29 2001 Manfred Hollstein <manfredh@redhat.com>
+- Add patch for new configuration item "desktop_auto_create_icons".
+
 * Mon Apr  2 2001 Preston Brown <pbrown@redhat.com>
 - check return code of mount for failure (ewt)
 
diff -upN /dev/null SOURCES/gmc-4.5.51-desktopicons.patch
--- /dev/null   Sat Mar 24 05:37:44 2001
+++ SOURCES/gmc-4.5.51-desktopicons.patch       Tue May 29 15:55:48 2001
@@ -0,0 +1,78 @@
+diff -up mc-4.5.51/gnome/gdesktop-prefs.c.orig
mc-4.5.51/gnome/gdesktop-prefs.c
+--- mc-4.5.51/gnome/gdesktop-prefs.c.orig      Mon Jul  3 16:32:12 2000
++++ mc-4.5.51/gnome/gdesktop-prefs.c   Tue May 29 15:14:36 2001
+@@ -37,6 +37,11 @@ struct _GDesktopPrefs {
+       guint bottom_to_top : 1;
+       guint rows_not_columns : 1;
+ 
++      /* Device rescanning options */
++      GtkWidget *auto_create_icons;   /* If the desktop has been set up
already, this option
++                                         can be used to toggle whether
device icons will be
++                                         created automatically or not. 
*/
++
+       /* Icon positioning options */
+       GtkWidget *auto_placement;
+       GtkWidget *snap_icons;
+@@ -255,6 +260,10 @@ create_position_widgets (GDesktopPrefs *
+ 
+       /* Snap and placement */
+ 
++      dp->auto_create_icons = create_check_box (_("Automatic icon
creation"),
++                                         desktop_auto_create_icons,
dp->pbox);
++      gtk_box_pack_start (GTK_BOX (vbox), dp->auto_create_icons, FALSE,
FALSE, 0);
++
+       dp->auto_placement = create_check_box (_("Automatic icon
placement"),
+                                              desktop_auto_placement,
dp->pbox);
+       gtk_box_pack_start (GTK_BOX (vbox), dp->auto_placement, FALSE,
FALSE, 0);
+@@ -346,6 +355,9 @@ desktop_prefs_apply (GDesktopPrefs *dp)
+       desktop_arr_r2l = dp->right_to_left;
+       desktop_arr_b2t = dp->bottom_to_top;
+       desktop_arr_rows = dp->rows_not_columns;
++
++      desktop_auto_create_icons = gtk_toggle_button_get_active (
++              GTK_TOGGLE_BUTTON (dp->auto_create_icons));
+ 
+       desktop_auto_placement = gtk_toggle_button_get_active (
+               GTK_TOGGLE_BUTTON (dp->auto_placement));
+diff -up mc-4.5.51/gnome/gdesktop.c.orig mc-4.5.51/gnome/gdesktop.c
+--- mc-4.5.51/gnome/gdesktop.c.orig    Tue May 29 15:03:38 2001
++++ mc-4.5.51/gnome/gdesktop.c Tue May 29 15:23:55 2001
+@@ -46,6 +46,7 @@ struct layout_slot {
+ 
+ 
+ int desktop_use_shaped_icons = TRUE;
++int desktop_auto_create_icons = TRUE;
+ int desktop_auto_placement = FALSE;
+ int desktop_snap_icons = FALSE;
+ int desktop_arr_r2l = FALSE;
+@@ -2441,7 +2442,7 @@ create_desktop_dir (void)
+               gdesktop_links_init ();
+               gmount_setup_devices ();
+               gprint_setup_devices ();
+-      } else {
++      } else if (desktop_auto_create_icons) {
+               /* Always rescan devices since the set of devices
+                * may have changed.
+                */
+diff -up mc-4.5.51/gnome/gdesktop.h.orig mc-4.5.51/gnome/gdesktop.h
+--- mc-4.5.51/gnome/gdesktop.h.orig    Mon Jul  3 16:32:13 2000
++++ mc-4.5.51/gnome/gdesktop.h Tue May 29 15:19:02 2001
+@@ -27,6 +27,7 @@
+ 
+ extern int desktop_use_shaped_icons;  /* Whether to use shaped icons or
not (for slow X servers) */
+ extern int desktop_use_shaped_text;     /* Shaped text for the icons on
the desktop */
++extern int desktop_auto_create_icons; /* Whether to automatically create
icons on every startup */
+ extern int desktop_auto_placement;    /* Whether to auto-place icons or
not (user placement) */
+ extern int desktop_snap_icons;                /* Whether to snap icons to
the grid or not */
+ extern int desktop_arr_r2l; /* Arrange from right to left */
+diff -up mc-4.5.51/src/setup.c.orig mc-4.5.51/src/setup.c
+--- mc-4.5.51/src/setup.c.orig Mon Jul  3 16:32:08 2000
++++ mc-4.5.51/src/setup.c      Tue May 29 15:55:07 2001
+@@ -262,6 +262,7 @@ static const struct {
+     { "desktop_use_shaped_icons", &desktop_use_shaped_icons },
+     { "desktop_use_shaped_text", &desktop_use_shaped_text },
+     { "desktop_auto_placement", &desktop_auto_placement },
++    { "desktop_auto_create_icons", &desktop_auto_create_icons },
+     { "desktop_snap_icons", &desktop_snap_icons },
+     { "desktop_arr_r2l", &desktop_arr_r2l },
+     { "desktop_arr_b2t", &desktop_arr_b2t },
Comment 1 Jonathan Blandford 2001-08-16 14:51:08 EDT
gmc is no longer the default file manager -- we use nautilus in this next release.

Bug forwarded to http://bugzilla.gnome.org/show_bug.cgi?id=59118

Note You need to log in before you can comment on or make changes to this bug.