Bug 427257 - Azureus does not work as expected with old .azureus directory
Summary: Azureus does not work as expected with old .azureus directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: azureus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lillian Angel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-02 15:00 UTC by Lillian Angel
Modified: 2008-01-15 23:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 18:51:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lillian Angel 2008-01-02 15:00:49 UTC
(In reply to comment #16)
> What problem are you seeing exactly? 
> The "Show Details" issue is definitely fixed in 3.0.3.4.
> 
> 
> 
After some more poking at this, this is what I can conclude:

When using the newly updated azureus package from rawhide on Fedora 8, I have 
found that if the user has an old .azureus settings directory (Generated by an 
older version of Azureus) in his home directory, Azureus will crash when 
selecting "Show Details" in the same manner as described in the original bug 
report description. If the user removes his old settings, thereby letting 
Azureus create a new .azureus directory, things work fine.

BUT, here's where the weird things start up! If I go to 
http://azureus.sourceforge.net and download the Azureus tarball for Linux, it 
does not crash when using settings originally created by an older version of 
Azureus.

Comment 1 Lillian Angel 2008-01-02 15:01:34 UTC
Problem copied from: https://bugzilla.redhat.com/show_bug.cgi?id=372931

(In reply to comment #25)
> (In reply to comment #24)
> > This is not the case with azureus-2.5.0.4-3.fc8, at least. Renaming my old
> > .azureus directory and starting from scratch was the first thing I tried, as 
> it
> > usually helps whenever Azureus acts up.
> > 
> For those of us who are addicted to statistics, deleting the .azureus 
> directory is not that great of an option, and especially since it works fine 
> if you use the Azureus you can find at azureus.sf.net, which I currently do.

Comment 2 Lillian Angel 2008-01-02 16:17:45 UTC
I can constantly reproduce this problem.

Removing azureus.config and azureus.config.bak fixes it. This is a workaround
for the time-being. I am looking into something better.

Comment 3 Lillian Angel 2008-01-02 18:51:01 UTC
A fix is being built into rawhide now, and should be available tomorrow sometime.

Comment 4 Fedora Update System 2008-01-15 23:04:30 UTC
azureus-3.0.3.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.