Bug 427269 - PPORT:RHEL51: Audio does not work after S3/S4 on Dell Precision M4300/M6300
PPORT:RHEL51: Audio does not work after S3/S4 on Dell Precision M4300/M6300
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity urgent
: rc
: ---
Assigned To: John Feeney
Martin Jenner
:
Depends On: 254067
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-02 11:17 EST by Rezwanul Kabir
Modified: 2010-10-22 17:28 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEL5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rezwanul Kabir 2008-01-02 11:17:53 EST
Description of problem:

With RHEL5.1 , upon resuming from S3/S4, audio does not work on M4300 and 
M6300.
Try , for example, "aplay /usr/share/sounds/pop.wav". No sound could be heard.

Version-Release number of selected component (if applicable):

alsa driver version 1.0.14rc3

How reproducible:

Always
Steps to Reproduce:
1.Enter S3/S4
2. Run "aplay /usr/share/sounds/pop.wav"
3.
  
Actual results:

No audio
Expected results:
 Audio should work

Additional info:

I have looked into the issue a little and found out the followings:

  1) The issue is resolved with alsa driver version 1.0.15
  2) The issue can also be resolved if you rmmod snd-hda-intel before 
suspending and modprobe it on resume.

 The fix in alsa driver 1.0.15 for this issue needs to be backported to 
RHEL5.1.
Comment 1 John Feeney 2008-01-03 16:21:43 EST
I used the RHEL-5.1 2.6.18-53 kernel on both the M4300 and M6300 and heard sound
via the headphone jack after resuming from s3 and s4 BUT not via the built-in
speakers so the scope of this bug is somewhat reduced. 

A fix for bz254067 was added to RHEL5.2 that handles suspend/resume and I heard
sound through the speakers with this patch in place. Thus, I would ask that this
bugzilla be tested with RHEL5.2. 

Comment 2 Rezwanul Kabir 2008-01-18 16:44:27 EST
Tested with the kernel below as mentioned by John in comment#1:
http://people.redhat.com/jfeeney/.bz254067/kernel-2.6.18-
45.el5.jfeeney.254067.1.x86_64.rpm

Confirming that the kernel above resolves the issue. This is a must have for 
RHEL5.2.



Comment 3 RHEL Product and Program Management 2008-02-01 17:38:05 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Peter Martuccelli 2008-04-03 13:40:10 EDT
Removing this one as an exception as we are just waiting on test results. 
Please close out as currentrelease when the results come back, (positive).
Comment 7 RHEL Product and Program Management 2008-04-03 13:43:36 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 8 John Feeney 2008-04-04 12:04:53 EDT
Rez,
Could we get this verified in a 5.2 snapshot release and get this closed as
"currentrelease" if fixed? It keeps drawing unwarranted attention. 
  Thanks.
    John
Comment 9 Rezwanul Kabir 2008-04-08 17:40:52 EDT
Verified as fixed in RHEL5.2 Snapshot3.
Comment 10 John Feeney 2008-04-09 12:31:28 EDT
Since this was found not to fail in RHEL5.2 (see comment #9), I am closing this
as CURRENTRELEASE. The fix for this bugzilla was included in the fix for 
bz254067 which has just been verified as working as well.

Note You need to log in before you can comment on or make changes to this bug.