Bug 427283 - "Permission Error" for SSM alter child channels
"Permission Error" for SSM alter child channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Sebastian Skracic
Bill C. Riemers
XPlanner-16309
:
Depends On:
Blocks: 428842
  Show dependency treegraph
 
Reported: 2008-01-02 14:32 EST by daryl herzmann
Modified: 2010-10-22 17:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 16:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daryl herzmann 2008-01-02 14:32:46 EST
Happy New Year,

I get a "Permission Error" when attempting to modify my System Set's child
channel subscriptions:

https://rhn.redhat.com/rhn/channel/ssm/ChildSubscriptions.do

I emailed with a Customer Service Associate who said this was a "Known issue",
but there was no bz entry for it yet.  So I generated one :)

thanks!
  daryl
Comment 1 daryl herzmann 2008-01-07 13:58:27 EST
Could this bug be triaged? thanks!
Comment 2 Máirín Duffy 2008-01-07 14:16:43 EST
Hi Daryl, we need more information in order to reproduce this issue, I sent you
an email with the information we need. You can reply to my email and I'll update
this bug with it in a private comment. Thanks.

Setting NEEDINFO.
Comment 6 daryl herzmann 2008-01-09 11:07:33 EST
I called support today for another issue and they can now access our account in
read-only status (FINALLY!)

Anyway, the tech on the phone saw the Permission Error.
Comment 7 Justin Sherrill 2008-01-10 12:24:27 EST
Just to note, I was able to reproduce in prod as well.  Fairly trivial to
reproduce actually.
Comment 8 Máirín Duffy 2008-01-10 12:25:59 EST
Justin how did you reproduce it?
Comment 9 John T. Rose 2008-01-10 12:44:05 EST
I reproduced it on multiple accounts. Add some systems to SSM as a normal user,
click the channel subscriptions button, kaboom. Seems to only affect hosted users.
Comment 10 Máirín Duffy 2008-01-10 13:03:29 EST
Ah that's weird, it must be some property of the accounts used? I couldn't
reproduce it in any of my accounts :-/
Comment 11 Amy Owens 2008-01-10 14:08:56 EST
AO 1/10/08-- reproduced in qa with an acct that was a normal user that was made
an admin of the system group-- in qa: aowens080110--- so go to system set
manager and click on Channels... 
Comment 16 Sebastian Skracic 2008-02-12 08:38:34 EST
The issue seems to be caused by incorrect ACL requirements stated in struts-
config.xml.  Should be fixed in r118528.
Comment 18 Amy Owens 2008-02-13 09:12:33 EST
jie verified on dev
Comment 19 daryl herzmann 2008-03-07 18:14:50 EST
Thanks for the help diagnosing and fixing this bug.  Is it set for production soon?

thanks!
  daryl
Comment 20 Bill C. Riemers 2008-03-14 16:52:57 EDT
verified on webqa
Comment 21 daryl herzmann 2008-04-07 15:10:10 EDT
Thanks guys, works4me now with rhn hosted 5.0.5 :)

Note You need to log in before you can comment on or make changes to this bug.