This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 42730 - Add lyx document processor to distribution
Add lyx document processor to distribution
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
http://www.lyx.org
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 14:40 EDT by kpinc
Modified: 2014-03-16 22:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 15:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kpinc 2001-05-29 14:40:21 EDT
From the website: 
   LyX is an advanced open source document processor running on many Unix
platforms and OS/2, and experimentally
under Windows/Cygwin. Unlike standard word processors, LyX encourages an
approach to writing based on the structure
of your documents, not their appearance. LyX lets you concentrate on
writing, leaving details of visual layout to the
software. 

   LyX produces high quality, professional output -- using LaTeX, an
industrial strength typesetting engine, in the
background; LyX is far more than a front-end to LaTeX, however. No
knowledge of LaTeX is necessary to use LyX,
although it will give a user more power. 
-----------------------------------------------------------------

Lyx is great for editing DocBook documents, like the Linux Howtos!

Note that lyx is distributed under a modified version of the GPL, modified
because lyx links to Xforms, the source for which is not available. 
However, RedHat already includes an xforms rpm in powertools.  (There's
talk of porting lyx off xforms.)
Comment 1 Tim Waugh 2001-05-30 04:41:54 EDT
xforms is not in Powertools.
Comment 2 Stefan Schwandter 2003-02-27 04:12:31 EST
Lyx now works with QT as well, and xforms is now available under the LGPL or
GPL, not sure.
Comment 3 John Levon 2003-04-13 16:18:29 EDT
Can this please be re-opened ? The original reason given
no longer applies: xforms is now GPLed and LyX 1.3.0 upwards 
can build against Qt anyway.

https://savannah.nongnu.org/projects/xforms/
Comment 4 Tim Waugh 2003-04-24 08:00:46 EDT
Not sure I like the idea of adding *another* way of processing documents; we
already have several word processors and two DocBook tool chains.
Comment 5 kop 2003-04-24 10:43:46 EDT
Lyx feeds the top of the docbook tool chains, as well as directly
into TeX.  It's niether a word processor or a text processor, but
designed from the ground up as a content editor -- layout/style being
left to the toolchain it feeds.  This is a significantly different
approach than that taken by word processors, which have a strong emphasis
on "look", while retaining a word processor like ease of use.

Lyx is really a docbook/TeX extension.

Word is OpenOffice 1.1 will feed docbook, which should improve it's
html output.  But OO will no doubt retain a strong integration between
content and look.

Document production needs Lyx for the same reason that web sites need
template engines (like the Smarty PHP Template system http://smarty.php.net/)
because the separation between content and presentation makes sense.
Comment 6 Tim Waugh 2003-04-24 10:58:23 EDT
Can you edit DocBook to any real degree in LyX yet?
Comment 7 John Levon 2003-04-24 11:02:01 EDT
It's certainly *possible*, but is a long way from what we'd like.

However, lyx does have a real unique value in terms of the LaTeX
output.
Comment 8 larsbj 2004-04-28 13:34:04 EDT
It would be really great to see the addition of LyX to Fedora Core 3
or any earlier version if possible.
Comment 9 John Levon 2004-04-28 13:45:28 EDT
Lars, see https://bugzilla.fedora.us/show_bug.cgi?id=972

(Tangentially, somebody is working on www.blastwave.org packages for
LyX too, which is good)
Comment 10 Bill Nottingham 2005-03-01 15:55:49 EST
This is currently in Fedora Extras; I doubt it will be in Core in the near future.

Note You need to log in before you can comment on or make changes to this bug.