Bug 427317 - qemu-kvm no longer boots
Summary: qemu-kvm no longer boots
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kvm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-03 01:13 UTC by Tom London
Modified: 2008-01-16 04:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 04:02:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2008-01-03 01:13:46 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2008-01-03 01:16:10 UTC
[Shoot.... elbow hit the key....]
qemu-kvm no longer 'boots up' images.  Appears to get stuck fiddling with the clock.

Strace reports endless number of :
select(0, [], [], [], {0, 0})           = 0 (Timeout)
gettimeofday({1199318955, 648246}, NULL) = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 629962819}) = 0
ioctl(4, 0x4008ae61, 0xbf9da314)        = 0
ioctl(4, 0x4008ae61, 0xbf9da314)        = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 630512480}) = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 630690649}) = 0
timer_gettime(0, {it_interval={0, 0}, it_value={0, 0}}) = 0
timer_settime(0, 0, {it_interval={0, 0}, it_value={0, 14000000}}, NULL) = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 631352408}) = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 631531903}) = 0
clock_gettime(CLOCK_MONOTONIC, {8944, 631708745}) = 0
timer_gettime(0, {it_interval={0, 0}, it_value={0, 13206448}}) = 0
timer_settime(0, 0, {it_interval={0, 0}, it_value={0, 13000000}}, NULL) = 0
ioctl(5, 0xae80, 0)                     = -1 EINTR (Interrupted system call)
rt_sigtimedwait([USR2 ALRM IO], {si_signo=SIGALRM, si_code=SI_TIMER, si_pid=0,
si_uid=0, si_value={int=0, ptr=0}}, 0xbf9da4e8, 8) = 14
rt_sigaction(SIGALRM, NULL, {0x804d834, ~[KILL STOP RTMIN RT_1], 0}, 8) = 0
rt_sigtimedwait([USR2 ALRM IO], 0x8183e60) = -1 EAGAIN (Resource temporarily
unavailable)
select(0, [], [], [], {0, 0})           = 0 (Timeout)
gettimeofday({1199318955, 666181}, NULL) = 0

etc.

Happens every time.

Version: kvm-58-2.fc9.i386

Reverting to kvm-56-1.fc9 fixes....

Comment 2 Jeremy Katz 2008-01-03 01:26:53 UTC
Yeah, it looks like upstream broke compatibility with older modules... reported
there (see thread started by Rich Jones on kvm-devel earlier today)

Comment 3 Bill Nottingham 2008-01-16 04:02:48 UTC
Will be fixed in 59-1 or 58-3.


Note You need to log in before you can comment on or make changes to this bug.