Bug 427356 - OS will not boot from RAID, when multiple RAID configurations in system
Summary: OS will not boot from RAID, when multiple RAID configurations in system
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-03 13:07 UTC by Adam Cetnerowski
Modified: 2008-12-16 14:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 14:36:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of failed boot (80.72 KB, image/jpeg)
2008-01-03 13:07 UTC, Adam Cetnerowski
no flags Details

Description Adam Cetnerowski 2008-01-03 13:07:09 UTC
Description of problem:
When RH is installed on a RAID configuration and other RAID configurations are
configured in system, the OS fails to boot. 

How reproducible:
Always

Steps to Reproduce:
1. Create two RAIDs 0 on the same HDD sets (4 HDDs in example)
- first RAID uses only 100GB (strip=64k)
- second RAID uses the rest of capacity and is 128k strip
2. Install RHEL(eg. Server 32) on the first RAID setup.
  
Actual results:
OS does not boot. 

Expected results:
OS should boot normally.

Comment 1 Adam Cetnerowski 2008-01-03 13:07:09 UTC
Created attachment 290725 [details]
screenshot of failed boot

Comment 2 Milan Broz 2008-01-04 12:59:17 UTC
"Red Hat nash version 5.1.19.6 starting" ... No RAID sets.

Reassigning to anaconda, probably wrong nash script generated during installation.

Comment 3 Chris Lumens 2008-12-10 19:21:57 UTC
Can you test with the latest 5.3 snapshot?  There's been a large number of RAID-related bugs and fixes going into the last couple snapshots, so there's a high likelihood this bug is fixed.  If you are still seeing problems, attaching the /var/log/anaconda.log and /var/log/anaconda.syslog from the installed system (which you can get by booting via rescue mode) to this bug report would be very helpful.  Thanks.

Comment 4 Jacek Danecki 2008-12-12 12:38:21 UTC
(In reply to comment #3)
> Can you test with the latest 5.3 snapshot?  There's been a large number of
> RAID-related bugs and fixes going into the last couple snapshots, so there's a
> high likelihood this bug is fixed.  If you are still seeing problems, attaching
> the /var/log/anaconda.log and /var/log/anaconda.syslog from the installed
> system (which you can get by booting via rescue mode) to this bug report would
> be very helpful.  Thanks.

We can't reproduced this bug on snap 5.

Comment 5 Denise Dumas 2008-12-16 14:36:47 UTC
Based on comment 4, I am closing this as fixed in rhel 5.3


Note You need to log in before you can comment on or make changes to this bug.