Bug 427382 - regression: vgreduce removes all pvs when only one is specified
regression: vgreduce removes all pvs when only one is specified
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.6.z
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Milan Broz
Corey Marthaler
GSSApproved
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 12:12 EST by Corey Marthaler
Modified: 2013-02-28 23:06 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2008-0048
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 08:10:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-01-03 12:12:50 EST
Description of problem:

[root@taft-04 ~]# pvscan
  PV /dev/sda2   VG VolGroup00   lvm2 [68.12 GB / 32.00 MB free]
  PV /dev/sdb1                   lvm2 [135.67 GB]
  PV /dev/sdc1                   lvm2 [135.67 GB]
  PV /dev/sdd1                   lvm2 [135.67 GB]
  PV /dev/sde1                   lvm2 [135.67 GB]
  PV /dev/sdf1                   lvm2 [135.67 GB]
  PV /dev/sdg1                   lvm2 [135.67 GB]
  PV /dev/sdh1                   lvm2 [135.67 GB]
  Total: 8 [1017.78 GB] / in use: 1 [68.12 GB] / in no VG: 7 [949.66 GB]

[root@taft-04 ~]# vgcreate test /dev/sd[bcdefgh]1
  Volume group "test" successfully created

[root@taft-04 ~]# pvscan
  PV /dev/sdb1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sdc1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sdd1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sde1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sdf1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sdg1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sdh1   VG test         lvm2 [135.66 GB / 135.66 GB free]
  PV /dev/sda2   VG VolGroup00   lvm2 [68.12 GB / 32.00 MB free]
  Total: 8 [1017.77 GB] / in use: 8 [1017.77 GB] / in no VG: 0 [0   ]

[root@taft-04 ~]# vgreduce test /dev/sdb1
  Removed "/dev/sdb1" from volume group "test"
  Removed "/dev/sdc1" from volume group "test"
  Removed "/dev/sdd1" from volume group "test"
  Removed "/dev/sde1" from volume group "test"
  Removed "/dev/sdf1" from volume group "test"
  Removed "/dev/sdg1" from volume group "test"
  Can't remove final physical volume "/dev/sdh1" from volume group "test"

[root@taft-04 ~]# echo $?
5


Version-Release number of selected component (if applicable):
2.6.9-67.ELsmp
lvm2-2.02.27-2.el4_6.1
Comment 2 RHEL Product and Program Management 2008-01-03 12:36:31 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 Milan Broz 2008-01-08 09:05:01 EST
Fixed in lvm2-2.02.27-2.el4_6.2.
Comment 9 Corey Marthaler 2008-01-08 14:41:20 EST
Fix verified in lvm2-2.02.27-2.el4_6.2.
Comment 11 errata-xmlrpc 2008-01-16 08:10:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0048.html

Note You need to log in before you can comment on or make changes to this bug.