Bug 427415 - Yum says packages need a shared library which is not available. But it is installed.
Yum says packages need a shared library which is not available. But it is ins...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 13:08 EST by Søren Sandmann Pedersen
Modified: 2014-06-18 05:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 15:54:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Søren Sandmann Pedersen 2008-01-03 13:08:08 EST
Description of problem:

Yum says packages need a shared library which is not available. But it is installed.

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package mkinitrd needs libparted-1.8.so.6, this is not available.
Package nash needs libparted-1.8.so.6, this is not available.
Complete!
dhcp83-49:~% ls -l /usr/lib/libparted-1.8.*
lrwxrwxrwx 1 root root     22 2007-12-19 15:34 /usr/lib/libparted-1.8.so.6 ->
libparted-1.8.so.6.0.0
-rwxr-xr-x 1 root root 424068 2007-10-04 16:29 /usr/lib/libparted-1.8.so.6.0.0


Version-Release number of selected component (if applicable):
dhcp83-49:~% rpm -q yum
yum-3.2.8-2.fc9


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Seth Vidal 2008-01-03 21:15:38 EST
Can you give me the output of yum -d 7 of the whole command you were running?
otherwise I don't have any context to work from.

thanks
Comment 2 Søren Sandmann Pedersen 2008-01-04 15:47:54 EST
The command was just "sudo yum install mkinitrd", but now that I'm running it
again, it works, so probably something changed about the repository.

So feel free to close this bug.

Note You need to log in before you can comment on or make changes to this bug.