Bug 427435 - Update to Squid 3
Update to Squid 3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
: 176028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 14:57 EST by Trever Adams
Modified: 2016-07-26 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 09:33:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)
New Spec file (29.24 KB, text/x-rpm-spec)
2008-01-03 14:58 EST, Trever Adams
no flags Details
Updated build patch (4.85 KB, patch)
2008-01-03 14:58 EST, Trever Adams
no flags Details | Diff
Updated config patch (2.71 KB, patch)
2008-01-03 14:59 EST, Trever Adams
no flags Details | Diff
Updated location patch (1.42 KB, patch)
2008-01-03 14:59 EST, Trever Adams
no flags Details | Diff
Updated perl path patch (409 bytes, patch)
2008-01-03 14:59 EST, Trever Adams
no flags Details | Diff
Updated smb path patch (1.89 KB, patch)
2008-01-03 15:01 EST, Trever Adams
no flags Details | Diff

  None (edit)
Description Trever Adams 2008-01-03 14:57:16 EST
Description of problem:
Squid 3 has working ICAP and some other nice things. I would like to see this
updated.

Most of the current patches are no longer necessary. I have attached an updated
(not the changelog) spec file, and updated patches. The patches may not be
necessary as most of this is now done with other means (configure options,
variables, etc.). I leave that up to the packager. All of the older patches are
either folded into the upstream package, or are no longer relevant.
Comment 1 Trever Adams 2008-01-03 14:58:08 EST
Created attachment 290771 [details]
New Spec file
Comment 2 Trever Adams 2008-01-03 14:58:46 EST
Created attachment 290772 [details]
Updated build patch
Comment 3 Trever Adams 2008-01-03 14:59:11 EST
Created attachment 290773 [details]
Updated config patch
Comment 4 Trever Adams 2008-01-03 14:59:34 EST
Created attachment 290774 [details]
Updated location patch
Comment 5 Trever Adams 2008-01-03 14:59:59 EST
Created attachment 290775 [details]
Updated perl path patch
Comment 6 Trever Adams 2008-01-03 15:01:00 EST
Created attachment 290776 [details]
Updated smb path patch

This is the last patch needed/wanted. I have been using these files and squid 3
(RC and other) for months. They work fine. STABLE1 gave a speed increase versus
all of the others.
Comment 7 Martin Nagy 2008-01-22 05:16:04 EST
*** Bug 176028 has been marked as a duplicate of this bug. ***
Comment 8 Martin Nagy 2008-01-23 09:33:09 EST
Thanks for the patches, squid-3.0.STABLE1-1.fc9 is now in rawhide. Please submit
any bugs you might find.
Comment 9 Trever Adams 2008-01-23 18:30:53 EST
I currently do not have any rawhide machines working right, so I will not be
testing for a bit. I will report any bugs when I do. Thank you.
Comment 10 shrek-m 2008-01-24 10:35:52 EST
thanks,

yum update is ok

squid3 works after the update with the old squid.conf 'ncsa_auth' or 'acl
192.168.10.0/24'


one security question with the new v3 squid.conf
i am confused that per default all localnets are allowed :-(
imho this is a really bad idea.


# grep localnet /etc/squid/squid.conf.rpmnew
acl localnet src 10.0.0.0/8     # RFC1918 possible internal network
acl localnet src 172.16.0.0/12  # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
# Adapt localnet in the ACL section to list your (internal) IP networks
http_access allow localnet
icp_access allow localnet
htcp_access allow localnet
Comment 11 Maxim Britov 2008-01-29 06:07:17 EST
Hm... squid 2.x still in active development. I need it.
http://www.squid-cache.org/Versions/v2/2.7/changesets/
http://www.squid-cache.org/Versions/v2/2.6/changesets/

IMHO Fedora should provide both squid (squid/squid3, squid2/squid)
Comment 12 Martin Nagy 2008-04-07 16:39:54 EDT
Package Change Request
======================
Package Name: squid
New Branches: F-9
Please add new branch, I'd like to update. Thanks!
Comment 13 Kevin Fenzi 2008-04-07 17:45:18 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.