This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 427548 - ocaml fails to build with tk8.5
ocaml fails to build with tk8.5
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ocaml (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 11:39 EST by Doug Chapman
Modified: 2008-01-06 17:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 17:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2008-01-04 11:39:54 EST
Description of problem:
In rawhide tk has been updated to version 8.5.  This causes ocaml to fail to
build since it does not build the LablTk stuff:

during configure:
Configuring LablTk...

tcl.h and tk.h version 8.5 found with "".

This version is not known.

Configuration failed, LablTk will not be built.


then later on rpm packaging fails because it is looking for the labltk files.

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/stublibs/dlllabltk.so

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/stublibs/dlltkanim.so

    File not found: /var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/bin/labltk

    File not found: /var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.cmi

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.cma

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.cmo

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/stublibs/dlllabltk.so

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/stublibs/dlltkanim.so

    File not found: /var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/bin/ocamlbrowser

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/labltktop

    File not found: /var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/pp

    File not found:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/tkcompiler

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.a

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.cmxa

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.cmx

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.mli

    File not found by glob:
/var/tmp/ocaml-3.10.0-7.fc9-root-root/usr/lib/ocaml/labltk/*.o


Version-Release number of selected component (if applicable):
ocaml-3.10.0-7.fc8.src.rpm


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gérard Milmeister 2008-01-06 17:40:26 EST
fixed.

Note You need to log in before you can comment on or make changes to this bug.