Bug 427549 - small python import problem
small python import problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 11:42 EST by Christian Krause
Modified: 2008-04-22 18:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixes the import problem (850 bytes, patch)
2008-01-04 11:42 EST, Christian Krause
no flags Details | Diff

  None (edit)
Description Christian Krause 2008-01-04 11:42:24 EST
Description of problem:
on my system "system-config-network-cmd" aborts with the following error:
------------------------

root@:~# system-config-network-cmd
An unhandled exception has occured.  This is most likely a bug.
Please file a detailed bug report against the component system-config-network at 
https://bugzilla.redhat.com/bugzilla
using the text below.
Component: system-config-network
Version: 1.4.3
Summary: TB
/usr/share/system-config-network/netconfpkg/NCDeviceList.py:102:load:NameError:
global name 'netconfpkg' is not defined
Traceback (most recent call last):
  File "/usr/sbin/system-config-network-cmd", line 281, in main
    devlists = [getDeviceList(), getHardwareList(),
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 302,
in getDeviceList
    __DVList.load()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 102,
in load
    profilelist = netconfpkg.NCProfileList.getProfileList()
NameError: global name 'netconfpkg' is not defined
----------------------------------

Version-Release number of selected component (if applicable):
system-config-network-tui-1.4.3-1.fc8.noarch.rpm

How reproducible:
- on one of my systems 100%, but depends on the network interface configuration

Additional info:

The reason is, that on this system the code path in
/usr/share/system-config-network/netconfpkg/NCDeviceList.py, line 321 is used,
which is not always the case (it has something to do with interface nicknames).

                profilelist = netconfpkg.NCProfileList.getProfileList()

But netconfpkg.NCProfileList isn't imported, so python will throw the mentioned
exception.

The fix is rather simple and non-invasive: just import the correct python
package. I've attached a patch.

It would be great if the patch could be applied and an update for F8 could be
pushed out.

Thanks!
Comment 1 Christian Krause 2008-01-04 11:42:24 EST
Created attachment 290852 [details]
patch fixes the import problem
Comment 2 Fedora Update System 2008-04-07 10:34:19 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-04-09 01:19:35 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2995
Comment 4 Fedora Update System 2008-04-22 18:38:22 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.