Bug 427591 - nxclient and freenx mouse and suspend issues
nxclient and freenx mouse and suspend issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 17:27 EST by Matt Baker
Modified: 2008-02-09 10:16 EST (History)
1 user (show)

See Also:
Fixed In Version: nxclient-3.1.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-09 10:16:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
resume error details (3.74 KB, text/plain)
2008-01-04 17:27 EST, Matt Baker
no flags Details
Available sessions dialog (15.71 KB, image/png)
2008-01-04 17:28 EST, Matt Baker
no flags Details

  None (edit)
Description Matt Baker 2008-01-04 17:27:53 EST
I have used nxclient and freenx on F6 and F7 with little issues, but I can't
seem to get it working very well on F8.  So here is my setup.  I have two F8
boxes.  I have the server and client setup on both of them because I remote back
and forth.  Here is some package information.

For this example I used this machine as the client.
[mlbaker@isPgm00New ~]$ rpm -qa | grep nx

nx-2.1.0-22.fc7

freenx-0.7.1-3.fc8

nxclient-3.1.0-2

[mlbaker@isPgm00New ~]$ 


For this example I used this machine as the server.
[mlbaker@localhost ~]$ rpm -qa | grep nx

nxclient-3.0.0-89

nx-2.1.0-22.fc7

freenx-0.7.1-3.fc8

[mlbaker@localhost ~]$ 



Issue #1)

When I connect It always brings up an “Available Sessions” dialog.  Even after I
have restarted the server machine.  I don't think this dialog should come up.  I
have not created any suspended sessions.  I will attach a screenshot of the
dialog.  If I click resume on one of the available sessions it brings up another
dialog that says “The NX client received an error from the server.  Please check
the details for more information.”  I will attach the details.

Issue #2)

If I click on the new button instead of resume on the Available Sessions dialog,
it logs me in and I can see the desktop of the other computer.  Everything works
great except for my mouse.  I will try to explain what I see.  The mouse pointer
that I see moves fine.  When I move the mouse to a folder and click on it it
does not work.  From my testing It seems that while my mouse pointer is moving
on my screen it is not moving on the server machine.  Wherever my mouse enters
the nxclient screen on the server it stays at that point.  So if I enter from
the top, it does not matter where I move the mouse if I right-click it will
always bring up the gnome panels dropdown.  If that was not clear let me know
and I can try again or make some screenshots.


Please let me know what other information you need.  Thank you!
Comment 1 Matt Baker 2008-01-04 17:27:53 EST
Created attachment 290868 [details]
resume error details
Comment 2 Matt Baker 2008-01-04 17:28:59 EST
Created attachment 290869 [details]
Available sessions dialog
Comment 3 Matt Baker 2008-02-09 10:16:58 EST
I re-tested the problem.  Nx and freenx did not change versions.  Nxclient
version changed to nxclient-3.1.0-6.i386.  Issue #2 (mouse issue) is fixed now.
 Issue #1 is not fixed, but it is a small issue.  I just have to hit new and it
works.  Thank you for your time!


Note You need to log in before you can comment on or make changes to this bug.