Bug 427592 - stormbaancoureur fails to start - a SoundEngineAlsa problem
stormbaancoureur fails to start - a SoundEngineAlsa problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: stormbaancoureur (Show other bugs)
8
All Linux
high Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 17:38 EST by Radek Bíba
Modified: 2008-02-26 03:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-26 03:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2008-01-04 17:38:21 EST
Description of problem:
The previous version wasn't producing any sound due to the pulseaudio
incompatibility described in the latest update text, but now stormbaancoureur
dies right after it starts, only some kind of splash screen with an engine is
launched, some short noise is produced, and this is printed:

Stormbaan Coureur is (c)2006-2007 by Bram Stolk
plib is (c) by Steve Baker
OpenDE is (c) by Russel L. Smith
OpenGL is version 1.3 Mesa 7.0.2
OpenGL renderer Mesa DRI Intel(R) 852GM/855GM 20061017 x86/MMX/SSE2
This platform does not support all required GL extensions to do hardware
accelerated shadowing.
open() on joystick device failed: No such file or directory
Cannot open /home/radek/.stormbaancoureur.keys
Using keyboard
Asked for 44100Hz playback rate, but got 44099Hz
soundenginealsa.cxx: requested period 500, got period 500, use batchsize 1
Number of samples per pixel: 0
Number of samples per pixel: 0
stormbaancoureur: ../src-common/soundenginealsa.cxx:198: float
SoundEngineAlsa::Sustain(): Assertion `!rc' failed.
Neúspěšně ukončen (SIGABRT)

(I suppose you understand the last line despite the i18n; I'm not really sure
what's being displayed under English locale in such a case)

Version-Release number of selected component (if applicable):
stormbaancoureur-2.0.0-1.fc8

How reproducible:
Always, at least on my up-to-date F8 box. Using pulseaudio on a sound card
running snd-intel8x0 (if it matters...)
Comment 1 Hans de Goede 2008-01-06 16:26:07 EST
Thanks for reporting this.

I've build a version with some more debugging output (and some other changes
which might completely fix this).

You can get it here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=328978

Scroll down, then click on the link for your architecture, scroll down again to
find the download links.

Note this is a scratch build and this will only be available for 6 days, please
test within the next 6 days.
Comment 2 Radek Bíba 2008-01-07 14:41:56 EST
Thanks, but the test version doesn't help :( . I'm getting a sightly different
error message, though:

...
Asked for 44100Hz playback rate, but got 44099Hz
soundenginealsa.cxx: period size SOLL-WERT 1000, IST-WERT 1000
soundenginealsa.cxx: buffer size SOLL-WERT 8000, IST-WERT 8000
Number of samples per pixel: 0
Number of samples per pixel: 0
Unexpected error getting sound-delay: Input/output error
stormbaancoureur: ../src-common/soundenginealsa.cxx:204: float
SoundEngineAlsa::Sustain(): Assertion `!rc' failed.
Neúspěšně ukončen (SIGABRT)
Comment 3 Hans de Goede 2008-01-07 17:49:46 EST
Lennart, adding you to the CC, perhaps you can help?

For some reason on the reports system alsa-plugins-pulseaudio's snd_pcm_delay()
is returning -EIO sometimes.
Comment 4 Hans de Goede 2008-02-25 08:48:25 EST
Radek,

Any chance you can retest this with the latest rawhide?
Comment 5 Radek Bíba 2008-02-26 02:42:39 EST
stormbaancoureur-2.1.0-1.fc9, installed from rawhide on my F8 box, works great!
(except it's not fully "fullscreen", I still see my taskbar, but that's totally
unrelated (is it a known bug, though?)).
Comment 6 Hans de Goede 2008-02-26 03:43:54 EST
(In reply to comment #5)
> stormbaancoureur-2.1.0-1.fc9, installed from rawhide on my F8 box, works great!
Good to hear! and thanks for testing.

> (except it's not fully "fullscreen", I still see my taskbar, but that's totally
> unrelated (is it a known bug, though?)).

Thats not really a bug, thats the result of it using glut, which doesn't have a
real fullscreen mode.

Since you are the only one with this problem, I'm going to close this as
rawhide, if I get other reports I'll make an F-8 update with the rawhide version.

Note You need to log in before you can comment on or make changes to this bug.