This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 427598 - 2.6.23.12-101.fc8 from koji has a little problem
2.6.23.12-101.fc8 from koji has a little problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 21:55 EST by Reindl Harald
Modified: 2008-02-10 14:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 14:31:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 9656 None None None Never

  None (edit)
Description Reindl Harald 2008-01-04 21:55:12 EST
All seems to be ok
WLAN (iwl3945) works without troubles, but dmesg shows some not so good messages


[harry@nb-rhsoft:~]$ uname -a
2.6.23.12-101.fc8 #1 SMP Fri Jan 4 16:49:51 EST 2008 i686 i686 i386 GNU/Linux


wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=63 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=1 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=1 cWmin=3 cWmax=7 burst=15
WARNING: at net/mac80211/rx.c:1663 __ieee80211_rx() (Not tainted)
 [<f89226b6>] __ieee80211_rx+0x3a6/0xd2a [mac80211]
 [<f887e698>] scsi_next_command+0x25/0x2f [scsi_mod]
 [<f887e84c>] scsi_end_request+0xa1/0xab [scsi_mod]
 [<f887e9f1>] scsi_io_completion+0x158/0x36a [scsi_mod]
 [<f8915c65>] ieee80211_tasklet_handler+0x3f/0xb9 [mac80211]
 [<c0431eea>] tasklet_action+0x58/0xb8
 [<c0431e02>] __do_softirq+0x66/0xd3
 [<c04073d5>] do_softirq+0x6c/0xce
 [<c0444685>] tick_do_update_jiffies64+0x15/0xa8
 [<c044019b>] ktime_get+0xf/0x2b
 [<c045bb43>] handle_edge_irq+0x0/0xfc
 [<c0431cc5>] irq_exit+0x38/0x6b
 [<c04074d6>] do_IRQ+0x9f/0xb9
 [<c05260fe>] acpi_hw_register_read+0xf1/0x156
 [<c0405b6f>] common_interrupt+0x23/0x28
 [<c0538122>] acpi_idle_enter_bm+0x279/0x2ee
 [<c05a23e1>] cpuidle_idle_call+0x5c/0x7f
 [<c05a2385>] cpuidle_idle_call+0x0/0x7f
 [<c040340b>] cpu_idle+0xab/0xcc
 [<c073fa6c>] start_kernel+0x32c/0x334
 [<c073f177>] unknown_bootoption+0x0/0x195
 =======================
Comment 1 Reindl Harald 2008-01-07 13:58:55 EST
Yes it only appears to 2.6.23.12-101.fc8
If have installed the following kernels from koji-buildserver (no one of them
was ever released public) and build 101 is the first with this error at end of
dmesg.

My configuration is a iwl3945 witdh static-ip and wpa2 with wpa_supplicant, wlan
works fine - the message in dmesg makes no problems in any way - but it is new
in build 101.

title Fedora (2.6.23.12-101.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.12-101.fc8 ro root=LABEL=/ selinux=0
nodmraid acpi_osi=Linux acpi_apic_instance=0
        initrd /boot/initrd-2.6.23.12-101.fc8.img
title Fedora (2.6.23.12-99.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.12-99.fc8 ro root=LABEL=/ selinux=0 nodmraid
        initrd /boot/initrd-2.6.23.12-99.fc8.img
title Fedora (2.6.23.12-98.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.12-98.fc8 ro root=LABEL=/ selinux=0 nodmraid
        initrd /boot/initrd-2.6.23.12-98.fc8.img
title Fedora (2.6.23.10-97.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.10-97.fc8 ro root=LABEL=/ selinux=0 nodmraid
        initrd /boot/initrd-2.6.23.10-97.fc8.img
title Fedora (2.6.23.10-96.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.10-96.fc8 ro root=LABEL=/ selinux=0 nodmraid
        initrd /boot/initrd-2.6.23.10-96.fc8.img
title Fedora (2.6.23.9-90.fc8)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.23.9-90.fc8 ro root=LABEL=/ selinux=0 nodmraid
        initrd /boot/initrd-2.6.23.9-90.fc8.img




> Hi Reindl,
> 
>  you have reported the above bug -- pointer to 
> this link can be found also at:
>
>
http://www.kerneloops.org/raw.php?rawid=2682&msgid=﷒0﷓
>
> Does this bug appear only in 2.6.23.12-101.fc8, 
> or even in some older RH kernels? Could 
> you please describe the steps you are 
> performing to force this warning? Like 
> you just normally run your wlan0 device,
> or you make something special and this warning
> appears? Does it appear on a regular base?
Comment 2 Reindl Harald 2008-01-10 05:19:01 EST
Hmm same with 2.6.23.13-104.fc8

IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
ip_tables: (C) 2000-2006 Netfilter Core Team
Netfilter messages via NETLINK v0.30.
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:17:9a:46:62:e5
wlan0: RX authentication from 00:17:9a:46:62:e5 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:17:9a:46:62:e5
wlan0: RX AssocResp from 00:17:9a:46:62:e5 (capab=0x431 status=0 aid=1)
wlan0: associated
wlan0 (WE) : Wireless Event too big (320)
wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=63 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=1 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=1 cWmin=3 cWmax=7 burst=15
WARNING: at net/mac80211/rx.c:1693 __ieee80211_rx_handle_packet() (Not tainted)
 [<f89246ef>] __ieee80211_rx_handle_packet+0xa7/0x9c4 [mac80211]
 [<f897f42d>] iwl3945_rx_reply_rx+0x80d/0x818 [iwl3945]
 [<c04e49f5>] elv_queue_empty+0x1d/0x1e
 [<c04e83f7>] blk_run_queue+0x1f/0x63
 [<f887e698>] scsi_next_command+0x25/0x2f [scsi_mod]
 [<f887e84c>] scsi_end_request+0xa1/0xab [scsi_mod]
 [<f887e9f1>] scsi_io_completion+0x158/0x36a [scsi_mod]
 [<f8925d01>] __ieee80211_rx+0x373/0x3c2 [mac80211]
 [<f8917c7a>] ieee80211_tasklet_handler+0x3f/0xb9 [mac80211]
 [<c047d212>] __slab_free+0x5c/0x216
 [<c0431ee6>] tasklet_action+0x58/0xb8
 [<c0431dfe>] __do_softirq+0x66/0xd3
 [<c04073d5>] do_softirq+0x6c/0xce
 [<c044467d>] tick_do_update_jiffies64+0x15/0xa8
 [<c0440197>] ktime_get+0xf/0x2b
 [<c045bb3b>] handle_edge_irq+0x0/0xfc
 [<c0431cc1>] irq_exit+0x38/0x6b
 [<c04074d6>] do_IRQ+0x9f/0xb9
 [<c0526256>] acpi_hw_register_read+0xf1/0x156
 [<c0405b6f>] common_interrupt+0x23/0x28
 [<c053827a>] acpi_idle_enter_bm+0x279/0x2ee
 [<c05a2541>] cpuidle_idle_call+0x5c/0x7f
 [<c05a24e5>] cpuidle_idle_call+0x0/0x7f
 [<c040340b>] cpu_idle+0xab/0xcc
 [<c073fa6c>] start_kernel+0x32c/0x334
 [<c073f177>] unknown_bootoption+0x0/0x195
 =======================
Comment 3 John W. Linville 2008-01-10 08:40:48 EST
This issue is well understood upstream.  Please note that this is merely a 
warning and only indicates a true problem on a handful of architectures (none 
of them "mainstream").

Should anyone decide to add "me too" comments, please indicate what wireless 
hardware you are using (or just include 'lspci -n' output) when you see the 
WARNING...thanks!
Comment 4 Reindl Harald 2008-01-11 05:14:30 EST
Same with build from last night

[harry@nb-rhsoft:~]$ uname -a
Linux nb-rhsoft 2.6.23.13-105.fc8 #1 SMP Thu Jan 10 21:15:15 EST 2008 i686 i686
i386 GNU/Linux

_________________

wlan0: associated
wlan0 (WE) : Wireless Event too big (320)
wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=63 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=1 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=1 cWmin=3 cWmax=7 burst=15
WARNING: at net/mac80211/rx.c:1693 __ieee80211_rx_handle_packet() (Not tainted)
 [<f892b6ef>] __ieee80211_rx_handle_packet+0xa7/0x9c4 [mac80211]
 [<f898642d>] iwl3945_rx_reply_rx+0x80d/0x818 [iwl3945]
 [<c042535f>] inc_nr_running+0x13/0x26
 [<c0427c65>] try_to_wake_up+0x2ef/0x2f9
 [<f887e9f1>] scsi_io_completion+0x158/0x36a [scsi_mod]
 [<f892cd01>] __ieee80211_rx+0x373/0x3c2 [mac80211]
 [<f891ec7a>] ieee80211_tasklet_handler+0x3f/0xb9 [mac80211]
 [<c0431ee6>] tasklet_action+0x58/0xb8
 [<c0431dfe>] __do_softirq+0x66/0xd3
 [<c04073d5>] do_softirq+0x6c/0xce
 [<c044429d>] tick_broadcast_oneshot_control+0x8a/0xda
 [<c045bb3b>] handle_edge_irq+0x0/0xfc
 [<c0431cc1>] irq_exit+0x38/0x6b
 [<c04074d6>] do_IRQ+0x9f/0xb9
 [<c0526256>] acpi_hw_register_read+0xf1/0x156
 [<c0405b6f>] common_interrupt+0x23/0x28
 [<c053827a>] acpi_idle_enter_bm+0x279/0x2ee
 [<c05a2541>] cpuidle_idle_call+0x5c/0x7f
 [<c05a24e5>] cpuidle_idle_call+0x0/0x7f
 [<c040340b>] cpu_idle+0xab/0xcc
 [<c073fa6c>] start_kernel+0x32c/0x334
 [<c073f177>] unknown_bootoption+0x0/0x195
 =======================
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
Comment 5 Reindl Harald 2008-01-18 04:45:41 EST
[harry@nb-rhsoft:~]$ uname -a
Linux nb-rhsoft 2.6.23.14-111.fc8 #1 SMP Thu Jan 17 18:18:57 EST 2008 i686 i686
i386 GNU/Linux


wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=63 burst=0
wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
wlan0: WMM queue=1 aci=2 acm=0 aifs=1 cWmin=7 cWmax=15 burst=30
wlan0: WMM queue=0 aci=3 acm=0 aifs=1 cWmin=3 cWmax=7 burst=15
WARNING: at net/mac80211/rx.c:1693 __ieee80211_rx_handle_packet() (Not tainted)
 [<f89246eb>] __ieee80211_rx_handle_packet+0xa7/0x9c4 [mac80211]
 [<f898504b>] iwl3945_rx_reply_rx+0x80d/0x818 [iwl3945]
 [<c042535f>] inc_nr_running+0x13/0x26
 [<c0427c65>] try_to_wake_up+0x2ef/0x2f9
 [<f8925cfd>] __ieee80211_rx+0x373/0x3c2 [mac80211]
 [<f8917c7a>] ieee80211_tasklet_handler+0x3f/0xb9 [mac80211]
 [<c0431ee6>] tasklet_action+0x58/0xb8
 [<c0431dfe>] __do_softirq+0x66/0xd3
 [<c04073d5>] do_softirq+0x6c/0xce
 [<c04446fb>] tick_do_update_jiffies64+0x93/0xa8
 [<c045bb3b>] handle_edge_irq+0x0/0xfc
 [<c0431cc1>] irq_exit+0x38/0x6b
 [<c04074d6>] do_IRQ+0x9f/0xb9
 [<c0526266>] acpi_hw_register_read+0xf1/0x156
 [<c0405b6f>] common_interrupt+0x23/0x28
 [<c053828a>] acpi_idle_enter_bm+0x279/0x2ee
 [<c05a2551>] cpuidle_idle_call+0x5c/0x7f
 [<c05a24f5>] cpuidle_idle_call+0x0/0x7f
 [<c040340b>] cpu_idle+0xab/0xcc
 [<c073fa6c>] start_kernel+0x32c/0x334
 [<c073f177>] unknown_bootoption+0x0/0x195
 =======================
Comment 6 John W. Linville 2008-01-18 10:36:42 EST
Not surprising, since there have been no patches to fix this minor issue.

I'm sorry that it annoys you to find this in your logs.  Hopefully the iwlwifi 
team will attend to the issue shortly.
Comment 7 Reindl Harald 2008-01-18 10:44:18 EST
OK - To make it easier please add a reply here if anythings change with a link
to the koji-package, so i will download it and make a report
Comment 8 John W. Linville 2008-01-18 10:48:03 EST
Certainly!
Comment 9 Christopher Brown 2008-01-29 17:25:16 EST
Does anyone mind if the bug subject gets changed to something a little more
helpful here?
Comment 10 John W. Linville 2008-02-07 14:31:25 EST
This should be resolved (i.e. the warning is gone) in the test kernels here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=34341

Similarly, the problem will be resolved shortly after F8 gets 2.6.24-based 
kernels.
Comment 11 Reindl Harald 2008-02-10 14:00:31 EST
Thank you for the information
I was so crazy to install the last f9-kernel on my f8-notebook
Seems to running perfectly, so i wait with good feelings for a native f8-build

Linux nb-rhsoft 2.6.24.1-26.fc9 #1 SMP Fri Feb 8 19:56:42 EST 2008 i686 i686
i386 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.