Bug 427614 - "package gnu.java.awt does not exist" errors when building java-1.7.0-icedtea
"package gnu.java.awt does not exist" errors when building java-1.7.0-icedtea
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-05 07:38 EST by Joachim Selke
Modified: 2008-02-13 12:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 12:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Selke 2008-01-05 07:38:49 EST
Since version 1.7.0.0-0.16.b19.snapshot the Koji build logs contain many errors
like "package gnu.java.awt does not exist" and "FAIL" messages also.
Nevertheless, the build process finishes successfully.

http://koji.fedoraproject.org/packages/java-1.7.0-icedtea/1.7.0.0/0.16.b19.snapshot.fc8/data/logs/i586/build.log
...
http://koji.fedoraproject.org/packages/java-1.7.0-icedtea/1.7.0.0/0.23.b24.snapshot.fc9/data/logs/i386/build.log

Is this a bug or is this behavior intended?
Comment 1 Lillian Angel 2008-01-07 17:44:12 EST
This is fixed in the repository and will be rebuilt into rawhide during the next
release.
Comment 2 Joachim Selke 2008-01-23 14:37:09 EST
The error messages are still there in java-1.7.0-icedtea-1.7.0.0-0.24.b24.fc9.
See the build log:
http://koji.fedoraproject.org/packages/java-1.7.0-icedtea/1.7.0.0/0.24.b24.fc9/data/logs/i386/build.log

Or do you mean b25 by "next release"?
Comment 3 Lillian Angel 2008-01-26 20:46:36 EST
Yes, b25.
Comment 4 Lillian Angel 2008-01-28 13:25:06 EST
Sorry, I didnt realize IcedTea was rebuilt.

It is almost impossible to get rid of all the mauve error messages. Sometimes
tests fail because of race conditions (and so on). We resolved all the major
problems. These messages are normal output.



+ echo ====================MAUVE TESTING========================
====================MAUVE TESTING========================
+ export DISPLAY=:20
+ DISPLAY=:20
+ Xvfb :20 -screen 0 1x1x24 -ac
+
/builddir/build/BUILD/icedtea-1.5/java-access-bridge-1.19.2/../openjdk/build/linux-i586/j2sdk-image/bin/java
Harness -vm
/builddir/build/BUILD/icedtea-1.5/java-access-bridge-1.19.2/../openjdk/build/linux-i586/j2sdk-image/bin/java
-file /builddir/build/SOURCES/mauve_tests -timeout 30000
+ tee mauve_output
_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
SELinux: SELinux not enabled, disabling SELinux support.
FAIL: javax.swing.text.html.HTML.ElementTagAttributeTest
  line 59: Exception caught [1] -- forced fail
Exception in thread "Basic L&F File Loading Thread" java.lang.NullPointerException
	at
javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run0(BasicDirectoryModel.java:239)
	at
javax.swing.plaf.basic.BasicDirectoryModel$LoadFilesThread.run(BasicDirectoryModel.java:232)
javax.swing.event.ListDataEvent[type=1,index0=0,index1=0]
sun.misc.Launcher$AppClassLoader@1ba34f2
Jan 22, 2008 1:32:07 PM java.util.prefs.FileSystemPreferences$2 run
INFO: Created user preferences directory.
Exception in thread "Timer-1" java.lang.RuntimeException: eat it!!!
	at gnu.testlet.java.util.Timer.taskException$1.run(taskException.java:47)
	at java.util.TimerThread.mainLoop(Timer.java:550)
	at java.util.TimerThread.run(Timer.java:500)
300
240
-780
-720
0
-60
SELinux: SELinux not enabled, disabling SELinux support.
FAIL: java.awt.Panel.TestPanelRepaint
  Test timed out.  Use -timeout [millis] option to change the timeout value.
Position: 26, Limit: 26
Position: 26, Limit: 26
true

TEST RESULTS:
2 of 2570 tests failed.  1 total calls to harness.check() failed.
SELinux: SELinux not enabled, disabling SELinux support.
+ unset DISPLAY
+ echo ====================MAUVE TESTING END====================
====================MAUVE TESTING END====================
Comment 5 Lillian Angel 2008-02-13 12:56:46 EST
Will be in rawhide within the next couple of days.

Note You need to log in before you can comment on or make changes to this bug.