Bug 427628 - yum whatprovides with wildcard does not always work with -C
yum whatprovides with wildcard does not always work with -C
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-05 13:24 EST by Till Maas
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 12:52:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2008-01-05 13:24:30 EST
Description of problem:
When I run
yum -C whatprovides bas\?
and filelists.sqlite.bz2 are not cached, yum does not provide any results.
yum -C whatprovides bash
provides some results, though.

Version-Release number of selected component (if applicable):

yum-3.2.8-2.fc7

How reproducible:
always

Steps to Reproduce:
1. yum clean all
2. yum whatprovides bash
3. yum -C whatprovides bas?

Actual results:
Error: Caching enabled but no local cache of
//var/cache/yum/fedora/filelists.sqlite.bz2 from fedora

Expected results:
yum should report bash as a match and maybe warn that there may be other
matches, that could not be found because of missing data.

Additional info:
Comment 1 James Antill 2008-01-07 12:52:31 EST
 This is just yum doing the right thing, IMO. However by 3.2.9 we should have a
feature which will help greatly with this problem.
Comment 2 Till Maas 2008-01-07 14:11:04 EST
(In reply to comment #1)
>  This is just yum doing the right thing, IMO. However by 3.2.9 we should have a
> feature which will help greatly with this problem.

What is this feature?
Comment 3 James Antill 2008-01-07 17:09:17 EST
 The short version is that yum-updatesd will download the filelists so you'll
never get into the above situation.

Note You need to log in before you can comment on or make changes to this bug.