Bug 427649 - mkinitrd fails to load the proper scsi modules, causing a kernel panic on boot (/dev/root cannot be found)
mkinitrd fails to load the proper scsi modules, causing a kernel panic on boo...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 01:48 EST by Stewart Adam
Modified: 2008-02-02 10:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-02 10:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2008-01-06 01:48:38 EST
Description of problem:
I have three SATA drives, and for some reason ever since I installed rawhide
about a month ago, mkinitrd fails to load the proper scsi modules for my drive.
Seeing as such, booting up any new kernels past the ones I was using in F8
result in a kernel panic (/dev/root cannot be found)

Version-Release number of selected component (if applicable):
kernel-2.6.23.8-63.fc8 <-- works
kernel-2.6.24-0.133.rc6.git8.fc9 <-- does not
mkinitrd-6.0.27-2.fc9
kudzu-1.2.81-1

How reproducible:
Always

Steps to Reproduce:
1. Install a new kernel (or run mkinitrd manually with no additional options)
2. Boot
  
Actual results:
Kernel panic because the following modules are missing from the initrd image:
* ahci.ko
* libata.ko
* scsi_mod.ko
* scsi_wait_scan.ko

Expected results:
mkinitrd loads the correct scsi modules. A working image can be generated with
the "--force-scsi-probe --preload=scsi_mod --preload=libata --preload=ahci"
arguments.

Additional info:
I read that mkinitrd determines which modules it needs to store in the image
from /etc/modprobe.conf - Maybe this is a case of kudzu misconfiguring the
modprobe.conf file?

*** Relevant fstab entry:
LABEL=x86_64	/	ext3	defaults	1	1

*** Relevant grub.conf entries:
title Fedora (2.6.24-0.133.rc6.git8.fc9)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.24-0.133.rc6.git8.fc9 ro root=LABEL=x86_64 rhgb quiet
	initrd /boot/initrd-2.6.24-0.133.rc6.git8.fc9.img
title Fedora (2.6.23.8-63.fc8)
	root (hd0,0)
	kernel /boot/vmlinuz-2.6.23.8-63.fc8 ro root=LABEL=x86_64 rhgb quiet
	initrd /boot/initrd-2.6.23.8-63.fc8.img

*** Relevant lspci entries:
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02)
03:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI
Controller (rev 02)

One internal SATA drive is connected to the Intel ICH8 controller, this is the
drive where my current / is located. The other two SATA drives are connected via
eSATA to the JMicron controller. / was at one point on one of drives, where it
failed too (to test that I created a partition, copied all system files
preserving attributes and permissions, relabeled partitions and rebooted).
Comment 1 Stewart Adam 2008-01-06 01:49:31 EST
That fstab entry came out badly with tabs, hopefully it looks better with spaces:
LABEL=x86_64 / ext3 defaults 1 1
Comment 2 Stewart Adam 2008-01-31 23:59:19 EST
Just installed kernel 2.6.24-9.fc9 and all is well in terms of booting, but for
some reason my SATA drives now do 20MB/s rather than the regular 80MB/s on
hdparm -t...
Comment 3 Stewart Adam 2008-02-02 10:34:20 EST
I'll close this since it's been fixed in 2.6.24, I submitted 431312 about the
other problem.

Note You need to log in before you can comment on or make changes to this bug.