Bug 427694 - Thinkpad X61s fails to hibernate (hang with green screen)
Thinkpad X61s fails to hibernate (hang with green screen)
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2008-01-06 14:56 EST by Simon Karpen
Modified: 2008-03-26 16:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: kernel-2.6.25-0.105.rc5.fc9.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-26 16:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Simon Karpen 2008-01-06 14:56:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3pre) Gecko/2008010314 Fedora/1.9-0.beta2.6.fc9 Minefield/3.0b3pre

Description of problem:
When attempting to hibernate the laptop, the hibernate proceeds most of the way through then the laptop hangs with a green screen. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Click on gnome-power-manager and select "hibernate"
2. Watch laptop wedge with green screen
3. Power cycle laptop to revive; does not resume from almost-complete hibernate

Actual Results:
Laptop hangs almost-hibernated with green screen

Expected Results:
Normal suspend to disk

Additional info:
Suspend to disk (hibernate) worked fine in Fedora8.

Suspend to RAM ('suspend') now works perfectly; had backlight and other issues in Fedora 8 

(so we've gone from working suspend to disk but not RAM, to working suspend to RAM but not disk)
Comment 1 Kyle McMartin 2008-01-07 19:51:47 EST
reproduced here on my t61.
Comment 2 Kyle McMartin 2008-01-07 19:56:58 EST
I resume fine if I leave the suspend process going for long enough, does similar
occur for you?
Comment 3 Simon Karpen 2008-01-07 21:17:55 EST
Nope; I left the hibernate going for 7 minutes before I got bored and shut it
off. Power-on was a normal reboot, though it did say there was a suspend
signature in the swap space. 

Let me know if you need any other info. 
Comment 4 Charles R. Anderson 2008-02-07 19:36:43 EST
On my T61, I have a similar issue.  Suspend-to-RAM didn't work unless I removed
these modules before suspension, otherwise I got an immediate resume: 

SUSPEND_MODULES="ehci_hcd ohci_hcd iwl4965"

I found this mentioned in a few places:


Suspend-to-disk worked fine before adding the above, but since adding those
lines to the config file to remove the modules before suspending, hibernating
now gets stuck on the green screen.  If I wait long enough (basically, wait
until the blinking-moon LED goes out, then wait until the hard disk activity
light stops, then wait until the blinking-moon LED starts blinking again), I can
power down the laptop manually by holding the power button down for 10 seconds.
 Then it resumes fine on the next power up.
Comment 5 petrosyan 2008-02-23 03:49:01 EST
I have this bug on Fedora 8 (x86_64), with Thinkpad X61.

kernel- hibernates and resumes without any problems.
kernel- screen goes green, and I get a blinking moon light, but
the laptop never turns off. If you turn it off by holding down the power button
and then turn back on again, it resumes from hibernate and seems to be working
fine. I  am filing this bug report after resuming from a failed hibernation.

Should I open a separate bug for Fedora 8 as it seems to me that 2.6.24 kernel
is in Fedora 8 updates-testing now, and rawhide moved on to 2.6.25 now?
Comment 6 petrosyan 2008-03-09 01:14:46 EST
This bug is still present in kernel-
Comment 7 petrosyan 2008-03-11 17:49:27 EDT
Is this bug still present in Fedora rawhide? If not, I am going to change the
version number from "Fedora rawhide" to "Fedora 8".
Comment 8 Simon Karpen 2008-03-11 17:58:14 EDT
This bug is present in rawhide as of a week or two ago (when I last tested it),
at least in one form or another. 

Comment 9 Charles R. Anderson 2008-03-11 18:08:29 EDT
Regarding Comment #4, I no longer have this problem with newer rawhide/f9 kernels.

I still have this and I haven't tried removing it yet:

SUSPEND_MODULES="ehci_hcd ohci_hcd iwl4965"

but the system does suspend-to-ram and hibernate/suspend-to-disk just fine now,
including powering itself off.  The green screen problem has also gone away. 
The situation improved since at least kernel-2.6.25-0.87.rc3.git4.fc9, if not
before.  I'm now running kernel-2.6.25-0.101.rc4.git3.fc9 and it works fine still.
Comment 10 Simon Karpen 2008-03-12 07:02:07 EDT
With your unload_modules configuration and with
kernel-2.6.25-0.101.rc4.git3.fc9.x86_64, suspend to disk now works fine.

(I am seeing problems with suspend to ram, but that's a separate issue so I'm
going to close this bug)
Comment 11 petrosyan 2008-03-13 10:45:51 EDT
I am going to reopen this bug because it is still present in Fedora 8.
Comment 12 petrosyan 2008-03-26 16:03:12 EDT
I can not reproduce this bug in Fedora rawhide.

Note You need to log in before you can comment on or make changes to this bug.