Bug 427698 - PATCH: fix compiling of openal using c++ programs with gcc 4.3
PATCH: fix compiling of openal using c++ programs with gcc 4.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 16:23 EST by Hans de Goede
Modified: 2008-01-06 17:28 EST (History)
0 users

See Also:
Fixed In Version: openal-0.0.9-0.14.20060204cvs.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 17:28:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PATCH: fix compiling of openal using c++ programs with gcc 4.3 (1.07 KB, patch)
2008-01-06 16:23 EST, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2008-01-06 16:23:11 EST
The lastest c++ standard and thus, the latest g++ 4.3, does not allow the following:

typedef MYVoid void;

int some_function(MYVoid);

alc.h uses a construction like this, causing the compilation of openal using
programs to fail when compiled with gcc 4.3

gcc 4.3 is the intended compiler for F-9, so please fix this in rawhide asap.
Comment 1 Hans de Goede 2008-01-06 16:23:11 EST
Created attachment 290921 [details]
PATCH: fix compiling of openal using c++ programs with gcc 4.3
Comment 2 Andreas Bierfert 2008-01-06 17:28:42 EST
Sad to disappoint you but it was already fixed ;) Thanks for the bug report so...

* Fri Jan 04 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 0.0.0-0.14-20060204
- fix gcc43 build

Note You need to log in before you can comment on or make changes to this bug.