Bug 427715 - AttributeError: YumBackend instance has no attribute 'isodir'
Summary: AttributeError: YumBackend instance has no attribute 'isodir'
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 427717 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-07 01:23 UTC by Jens Petersen
Modified: 2008-01-07 15:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 15:03:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2008-01-07 01:23:27 UTC
Description of problem:
anaconda is backtracing towards the end of installing.

Version-Release number of selected component (if applicable):
anaconda-11.4.0.15-1

Steps to Reproduce:
1. default nfs install from boot.iso

Actual results:
anaconda 11.4.0.15 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 767, in complete
    if self.ayum._loopbackFile and (anaconda.mediaDevice or self.isodir):
  File "/usr/lib/anaconda/installmethod.py", line 30, in doMethodComplete
    anaconda.backend.complete(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 132, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 653, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1021, in <module>
    anaconda.intf.run(anaconda)
AttributeError: YumBackend instance has no attribute 'isodir'

Local variables in innermost frame:
self: <yuminstall.YumBackend instance at 0xb78b34cc>
anaconda: <__main__.Anaconda instance at 0xb7f33e2c>


Expected results:
no back

Additional information:
I can attach the full backtrace file if necessary.

Comment 1 Olof Johansson 2008-01-07 02:38:57 UTC
*** Bug 427717 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2008-01-07 15:03:30 UTC
This is fixed in today's build of anaconda.


Note You need to log in before you can comment on or make changes to this bug.