Bug 427794 - [RFE] backport patches to reduce wakeups
[RFE] backport patches to reduce wakeups
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
http://bugs.python.org/issue1583
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 11:42 EST by drago01
Modified: 2008-08-05 20:02 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.5.1-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 20:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2008-01-07 11:42:11 EST
Description of problem:

As noted in this blog post:
http://blogs.gnome.org/johan/2008/01/04/enough-wakeups-in-python-programs/ 
There are patches upstream (svn head) that add a new API to python to help
reducing wake ups. Since they wont be in an official release until python 2.6 I
think it makes sense to backport the patches and carry them in the rpm for a while.

See: http://bugs.python.org/issue1583

To take advantage of them we will need updated PyGObject and PyGT packages but
since they are released it should not be a problem to get them into fedora soon.
Comment 1 Paul W. Frields 2008-08-05 20:02:30 EDT
According to the changelog for the python package, this was fixed on 7 Jan 2008 and is in Fedora 9 now.

Note You need to log in before you can comment on or make changes to this bug.