Bug 427832 - Unneeded dependencies
Unneeded dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 427833 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 13:56 EST by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.21.91-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 10:54:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2008-01-07 13:56:14 EST
Description of problem:

Totem seems to have a number of unneeded dependencies. I am trying to get Totem
as the default media player in Xfce spin and I don't think all these are valid
dependencies. It might be possible to split some of them into a separate
totem-gnome package and leave totem with minimal dependencies such as gstreamer
for other use cases. 
  
Actual results:


yum install totem

=============================================================================
 Package                 Arch       Version          Repository Size
=============================================================================
 PolicyKit-gnome         i386       0.6-1.fc8        fedora         34 k
 fedora-gnome-theme      noarch     8.0.0-1.fc8      fedora         10 k
 fedora-icon-theme       noarch     1.0.0-1.fc8      fedora        115 k
 gnome-desktop           i386       2.20.2-1.fc8     updates       952 k
 gnome-keyring           i386       2.20.2-1.fc8     updates       210 k
 gnome-mime-data         noarch     2.18.0-2.fc7     fedora        724 k
 gnome-mount             i386       0.7-1.fc8        fedora        126 k
 gnome-themes            noarch     2.20.2-1.fc8     updates       2.5 M
 gnome-vfs2              i386       2.20.1-1.fc8     updates       1.1 M
 gstreamer-plugins-base  i386       0.10.15-1.fc8    updates       879 k
 gstreamer-plugins-good  i386       0.10.6-6.fc8     fedora        835 k
 libbonoboui             i386       2.20.0-1.fc8     fedora        352 k
 libgnome                i386       2.20.1-2.fc8     fedora        966 k
 libgnomeui              i386       2.20.1.1-1.fc8   fedora        1.0 M
 nautilus-extensions     i386       2.20.0-6.fc8     fedora        41 k
 nodoka-theme-gnome      noarch     0.3.2-2.fc8      fedora        11 k
 totem-plparser          i386       2.20.1-2.fc8     updates       42 k 


Expected results:

minimal dependencies.
Comment 1 Bastien Nocera 2008-01-07 14:25:00 EST
Those are the direct Totem dependencies:
 gnome-vfs2              i386       2.20.1-1.fc8     updates       1.1 M
 totem-plparser          i386       2.20.1-2.fc8     updates       42 k 
 libgnomeui              i386       2.20.1.1-1.fc8   fedora        1.0 M

Those are pulled in by dependencies:
 PolicyKit-gnome         i386       0.6-1.fc8        fedora         34 k
 fedora-gnome-theme      noarch     8.0.0-1.fc8      fedora         10 k
 fedora-icon-theme       noarch     1.0.0-1.fc8      fedora        115 k
 gnome-desktop           i386       2.20.2-1.fc8     updates       952 k
 gnome-keyring           i386       2.20.2-1.fc8     updates       210 k
 gnome-mime-data         noarch     2.18.0-2.fc7     fedora        724 k
 gnome-mount             i386       0.7-1.fc8        fedora        126 k
 gnome-themes            noarch     2.20.2-1.fc8     updates       2.5 M
 gstreamer-plugins-base  i386       0.10.15-1.fc8    updates       879 k
 gstreamer-plugins-good  i386       0.10.6-6.fc8     fedora        835 k
 libbonoboui             i386       2.20.0-1.fc8     fedora        352 k
 libgnome                i386       2.20.1-2.fc8     fedora        966 k
 nodoka-theme-gnome      noarch     0.3.2-2.fc8      fedora        11 k
 nautilus-extensions     i386       2.20.0-6.fc8     fedora        41 k

We can remove the nautilus-extensions dep by splitting out the nautilus property
tab, and adding it to the defaults in comps.
Comment 2 Bastien Nocera 2008-01-07 14:28:03 EST
*** Bug 427833 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2008-01-07 14:35:45 EST
The gnome-desktop dependency can also be removed, I removed it in SVN trunk.

The gnome-themes dep can't be removed, as otherwise some icons just wouldn't
appear (see bug 235819). Feel free to let me know if that's not the case anymore
(possibly using F9).
Comment 4 Rahul Sundaram 2008-01-07 14:57:45 EST
Thanks for the quick response. Much appreciated. 

Can you make available a new build of totem in rawhide and Fedora 8? I requested
this primarily because I can remove some unneeded dependencies in the Fedora 8
Xfce spin I am working on and would like to test this again with a newer totem.
Thanks. 

I am not sure of the gnome-themes dependency but I will check in rawhide again
and get back to you later. 
Comment 5 Bastien Nocera 2008-01-07 17:30:06 EST
I'm afraid I don't intend on doing any updates for F8 for this particular
feature, but it might fall in when I do an update.
Comment 6 Bastien Nocera 2008-01-25 10:54:32 EST
Removed the direct HAL and gnome-desktop dependencies, and split out the
nautilus tab.
Comment 7 Oliver Henshaw 2009-01-27 13:08:49 EST
There's still a "Requires: gnome-desktop >= 2.6.0" in the .spec file.

On current F10, 'yum installed totem' on a kde-live-cd derived install gives:

====================================================================================================
 Package                                Arch           Version                Repository       Size
====================================================================================================
Installing:
 totem                                  i386           2.24.3-1.fc10          fedora          2.3 M
Installing for dependencies:
 evolution-data-server                  i386           2.24.3-1.fc10          updates         4.0 M
 fuse-libs                              i386           2.7.4-1.fc10           fedora           73 k
 gnome-desktop                          i386           2.24.2-1.fc10          updates         1.0 M
 gstreamer-plugins-flumpegdemux         i386           0.10.15-4.fc10         fedora           63 k
 gstreamer-plugins-good                 i386           0.10.11-4.fc10         updates         1.1 M
 gvfs-fuse                              i386           1.0.3-4.fc10           updates          20 k
 iso-codes                              noarch         3.3-1.fc10             fedora          2.1 M
 solar-backgrounds                      noarch         0.92.0-1.fc10          fedora           13 M
 totem-gstreamer                        i386           2.24.3-1.fc10          fedora           69 k
 totem-pl-parser                        i386           2.24.3-1.fc10          updates         333 k
 xml-common                             noarch         0.6.3-26.fc10          fedora          7.4 k
Comment 8 Bastien Nocera 2009-01-27 19:47:35 EST
(In reply to comment #7)
> There's still a "Requires: gnome-desktop >= 2.6.0" in the .spec file.

Removed in rawhide. Please open new bugs in the future.

Note You need to log in before you can comment on or make changes to this bug.