Bug 427842 - Pirut crash
Pirut crash
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-07 14:47 EST by bochecha
Modified: 2008-01-08 12:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-08 12:15:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bochecha 2008-01-07 14:47:20 EST
Description of problem:
I tried to run pirut and it crashed opening a window with a traceback, asking to
post it here.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open pirut
Actual results:
Pirut crashed

Expected results:
Pirut should run normally, allowing me to add / remove softwares

Additional info:
Here is the trace :
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list
index out of range

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
  File "/usr/sbin/pirut", line 479, in main
  File "/usr/sbin/pirut", line 407, in run
  File "/usr/sbin/pirut", line 423, in doRefresh
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x8881c2c>
repos: ['livna-development', 'updates-source', 'livna-development-debuginfo',
'updates-testing', 'livna', 'updates-testing-source', 'livna-debuginfo',
'fedora', 'livna-source', 'InstallMedia', 'development-source',
'adobe-linux-i386', 'development', 'updates-debuginfo', 'fedora-debuginfo',
'livna-development-source', 'updates-testing-debuginfo', 'updates',
'livna-testing', 'fedora-source', 'development-debuginfo',
'livna-testing-debug', 'livna-testing-source', 'texlive']
repomirrors: {'InstallMedia': [], 'livna':
Comment 1 bochecha 2008-01-07 15:56:29 EST
Just tried something :

- disable Fedora-Install-Media.repo => no crash

- enable Fedora-Install-Media.repo while disabling fastestmirror plugin => no crash

Seems like we have an incompatibility between the plugin and the repo...
Comment 2 Jeremy Katz 2008-01-08 12:15:19 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.