Bug 427874 - util-linux-ng gets "excess command line argument" on update
util-linux-ng gets "excess command line argument" on update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 18:17 EST by Michal Jaegermann
Modified: 2008-02-13 00:09 EST (History)
0 users

See Also:
Fixed In Version: 2.13.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:09:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-07 18:17:03 EST
Description of problem:

On the last update I got on some machine:

  Updating  : util-linux-ng                ####################### [11/42]
install-info: excess command line argument `/usr/share/info/dir'

'rpm -q --scripts util-linux-ng' reveals the following lines:

/sbin/install-info /usr/share/info/ipc.info* /usr/share/info/dir
/sbin/install-info --del /usr/share/info/ipc.info* /usr/share/info/dir

The problem is that, likely after some past troubles on updates,
there are there both /usr/share/info/ipc.info and
/usr/share/info/ipc.info.gz while that script clearly expects only the
later.  The same "excess" would happen if ipc.info.gz would split
into a number of smaller files.

Results are not pretty although removing all of that and
reinstalling util-linux-ng fixes things up.  If we really want to
rely on that that /usr/share/info/ipc.info* expands to one name then
maybe an preinstallation part of a package script should start with

   rm -f /usr/share/info/ipc.info*

Version-Release number of selected component (if applicable):
util-linux-ng-2.13-3.2.fc8
Comment 1 Fedora Update System 2008-01-18 18:56:49 EST
util-linux-ng-2.13.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update util-linux-ng'
Comment 2 Fedora Update System 2008-02-13 00:09:01 EST
util-linux-ng-2.13.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.