Bug 427974 - kdepim: kmail doesn't apply new criteria to existing filters/please update to rev 748479
kdepim: kmail doesn't apply new criteria to existing filters/please update to...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 06:34 EST by Roland Wolters
Modified: 2015-07-13 13:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 13:40:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 154579 None None None Never

  None (edit)
Description Roland Wolters 2008-01-08 06:34:45 EST
Description of problem:
If I want to add a new criteria to an existing filter, the new criteria is not 
added when I press apply or ok. The bug is fixed upstream.

Version-Release number of selected component (if applicable):
$ rpm -q kdepim
kdepim-3.5.8-10.svn20071129.ent.fc8

How reproducible:
Take an existing filter in kmail, and try to add a new criteria (for example 
another To: address or whatever).

Steps to Reproduce:
1. Open kmail.
2. Open an existing e-mail filter.
3. Try to add another criteria there.
  
Actual results:
The criteria vanishes when apply or ok is pressed.

Expected results:
The criteria should stay there.

Additional info:
The bug is fixed upstream in rev 748479.
Comment 1 Rex Dieter 2008-01-08 15:00:53 EST
We're using the latest snapshot from:
http://apt.intevation.de/dists/etch/unstable/source/

will keep an eye out.  If it takes too long, may be worth extracting the patch
by hand.
Comment 2 Lukáš Tinkl 2008-01-09 03:59:45 EST
AFAICS we're not using the latest version (our version is dated 20071123 
whereas the latest intevation version is 20071204). I'll take care of updating
Comment 3 Rex Dieter 2008-01-09 06:19:19 EST
the 20071204 snapshot is in rawhide/devel.
Comment 4 Rex Dieter 2008-01-10 22:18:18 EST
Roland, can you try out this newer build?
http://koji.fedoraproject.org/koji/buildinfo?buildID=30822

Let us know if it helps.
Comment 5 Josip Deanovic 2008-01-11 11:43:32 EST
Hi!

It worked for me, thanks.

-- 
Josip Deanovic
Comment 6 Roland Wolters 2008-01-11 13:40:43 EST
Japp, works for me as well.
Comment 7 Fedora Update System 2008-01-15 17:59:24 EST
kdepim-3.5.8-11.svn20080109.ent.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-01-15 18:07:27 EST
kdepim-3.5.8-11.svn20080109.ent.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.