Bug 427985 - Brasero doesn't burn cds nor dvds
Brasero doesn't burn cds nor dvds
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: brasero (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 08:51 EST by markm
Modified: 2008-02-01 20:18 EST (History)
0 users

See Also:
Fixed In Version: 0.7.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 20:18:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2008-01-08 08:51:36 EST
Description of problem:

Brasero doesn't burn cds or dvds

Version-Release number of selected component (if applicable):

0.6.1-1.fc8@i386

How reproducible:

always (on two different laptops)

Steps to Reproduce:
1. open brasero
2. create data cd or dvd
3. press burn button
  
Actual results:

brasero insist that medium is not writeable

Expected results:

brasero burns cd

Additional info:

also it cannot overwrite dvd-rw (medium is not writable)
Comment 1 Denis Leroy 2008-01-08 09:24:53 EST
Well works for me here. What's the output of

cdrdao --device /dev/cdrom disk-info

(with a CD preferably, assuming /dev/cdrom is your device here)

Can you try with brasero 0.7.0 ?
(rpm here: http://www.poolshark.org/src/brasero-0.7.0-1.fc8.i386.rpm)
Comment 2 markm 2008-01-08 09:40:45 EST
[marek@Mareg ~]$ cdrdao /dev/cdrom disk-info
ERROR: Illegal command: /dev/cdrom

Cdrdao version 1.2.2 - (C) Andreas Mueller <andreas@daneb.de>
  SCSI interface library - (C) Joerg Schilling
  Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.


Usage: cdrdao <command> [options] [toc-file]
command:
  show-toc   - prints out toc and exits
  toc-info   - prints out short toc-file summary
  toc-size   - prints total number of blocks for toc
  read-toc   - create toc file from audio CD
  read-cd    - create toc and rip audio data from CD
  read-cddb  - contact CDDB server and add data as CD-TEXT to toc-file
  show-data  - prints out audio data and exits
  read-test  - reads all audio files and exits
  disk-info  - shows information about inserted medium
  discid     - prints out CDDB information
  msinfo     - shows multi session info, output is suited for scripts
  drive-info - shows drive information
  unlock     - unlock drive after failed writing
  blank      - blank a CD-RW
  scanbus    - scan for devices
  simulate   - shortcut for 'write --simulate'
  write      - writes CD
  copy       - copies CD


 Try 'cdrdao <command> -h' to get a list of available options

[marek@Mareg ~]$ cdrdao disk-info /dev/cdrom
Cdrdao version 1.2.2 - (C) Andreas Mueller <andreas@daneb.de>
  SCSI interface library - (C) Joerg Schilling
  Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

ERROR: Cannot open SCSI device '/dev/cdrecorder': Cannot open '/dev/cdrecorder'
Supported SCSI transports for this platform:

Transport name:         sg
Transport descr.:       Generic transport independent SCSI
Transp. layer ind.:
Target specifier:       bus,target,lun
Target example:         1,2,0
SCSI Bus scanning:      supported
Open via UNIX device:   not supported

Transport name:         pg
Transport descr.:       SCSI transport for ATAPI over Parallel Port
Transp. layer ind.:
Target specifier:       bus,target,lun
Target example:         1,2,0
SCSI Bus scanning:      supported
Open via UNIX device:   not supported

Transport name:         ATA
Transport descr.:       ATA Packet specific SCSI transport
Transp. layer ind.:     ATAPI:
Target specifier:       bus,target,lun
Target example:         ATAPI:1,2,0
SCSI Bus scanning:      supported
Open via UNIX device:   not supported

Transport name:         ATA
Transport descr.:       ATA Packet specific SCSI transport using sg interface
Transp. layer ind.:     ATA:
Target specifier:       bus,target,lun
Target example:         1,2,0
SCSI Bus scanning:      supported
Open via UNIX device:   not supported
ERROR: Please use option '--device [proto:]bus,id,lun', e.g. --device 0,6,0 or
--device ATA:0,0,0
ERROR: Cannot setup device /dev/cdrecorder.
[marek@Mareg ~]$ 
[marek@Mareg ~]$ 

Comment 3 markm 2008-01-08 09:41:26 EST
I haven't tried brasero 7.0, I will give it a try.

also, K3b burns everything without any problems.
Comment 4 Denis Leroy 2008-01-08 09:44:29 EST
You forgot --device:

cdrdao disk-info --device /dev/cdrom
Comment 5 markm 2008-01-08 09:48:31 EST
brasero 0.7 needed a libburn package, I have installed it, but it still won't
install because of:

Missing Dependency: libburn.so.0 is needed by package brasero

I've checked, in my /usr/lib I've got only libburn.so and libburn.so.4, I've
created symlink called libburn.so.0 but it didn't solve a problem.
Comment 6 markm 2008-01-08 09:49:18 EST
[marek@Mareg ~]$ cdrdao disk-info --device /dev/cdrom
Cdrdao version 1.2.2 - (C) Andreas Mueller <andreas@daneb.de>
  SCSI interface library - (C) Joerg Schilling
  Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

Using libscg version 'schily-0.8'

/dev/cdrom: TSSTcorp DVD+-RW TS-L632H   Rev: D200
Using driver: Generic SCSI-3/MMC - Version 2.0 (options 0x0000)

That data below may not reflect the real status of the inserted medium
if a simulation run was performed before. Reload the medium in this case.

CD-RW                : no
Total Capacity       : 79:57:74 (359849 blocks, 702/807 MB)
CD-R medium          : SONY Corporation
                       Short Strategy Type, e.g. Phthalocyanine
Recording Speed      : n/a
CD-R empty           : yes
[marek@Mareg ~]$ 
Comment 7 Denis Leroy 2008-01-08 10:01:28 EST
!@#$ ok sorry. Just recompiled it without libburn support. Can you download
brasero 0.7.0 again and reinstall it (with --force) :

http://www.poolshark.org/src/brasero-0.7.0-1.fc8.i386.rpm
Comment 8 markm 2008-01-08 10:09:16 EST
are you sure? :) I still get:

[root@Mareg ~]# rpm -Uvh brasero-0.7.0-1.fc8.i386.rpm 
error: Failed dependencies:
        libburn.so.0 is needed by brasero-0.7.0-1.fc8.i386
        libisofs.so.5 is needed by brasero-0.7.0-1.fc8.i386
[root@Mareg ~]# 

brasero was downloaded using wget 
Comment 9 markm 2008-01-08 10:20:50 EST
Ok, used --nodeps to install brasero and... looks like it works :)

I like the new look!

Thanks!
Comment 10 Denis Leroy 2008-01-08 10:22:37 EST
Fantastic. I'll push 0.7.0 to F-8.
Comment 11 Fedora Update System 2008-01-11 17:21:33 EST
brasero-0.7.0-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update brasero'
Comment 12 markm 2008-01-13 07:52:12 EST
brasero from updates-testing repo works fine for me :)

Thanks!
Comment 13 Fedora Update System 2008-02-01 20:18:53 EST
brasero-0.7.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.