Bug 427986 - Eclipse seg faults on IcedTea but not with Sun JVM
Summary: Eclipse seg faults on IcedTea but not with Sun JVM
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-08 13:52 UTC by Marc Wiriadisastra
Modified: 2008-02-04 21:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 19:32:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from running Starting application: 1219 !SESSION 2008-01-08 23:06:02.997 ----------------------------------------------- Output from running the -consolelog and -debug (3.88 KB, text/plain)
2008-01-08 14:12 UTC, Marc Wiriadisastra
no flags Details
Output using Sun's JRE (1.56 KB, text/plain)
2008-01-08 21:29 UTC, Marc Wiriadisastra
no flags Details
error log from eclipse (20.22 KB, text/plain)
2008-01-08 21:31 UTC, Marc Wiriadisastra
no flags Details

Description Marc Wiriadisastra 2008-01-08 13:52:36 UTC
Description of problem:
Eclipse segfaults when I delete a src file.  It also segfaults when I create a
package.  It deletes the package and deletes the source file but segfaults.


How reproducible:
Every time

Steps to Reproduce:
1.Load up Eclipse
2. Create a new package
3. Disappears but if I run it from console the output is Segmentation fault
  
Actual results:
Segmentation fault

Expected results:
It should remove the file, create the package or create the new file.

Additional info:
> - rpm -q eclipse-platform
eclipse-platform-3.3.0-30.fc8
> - for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done
[marc@Strike-Lap ~]$ for f in `rpm -qa | egrep "eclipse|swt"`; do echo
$f; rpm -qV $f; done
eclipse-ecj-3.3.0-30.fc8
eclipse-rcp-3.3.0-30.fc8
eclipse-jdt-3.3.0-30.fc8
tomcat5-jasper-eclipse-5.5.25-1jpp.1.fc8
eclipse-cvs-client-3.3.0-30.fc8
libswt3-gtk2-3.3.0-30.fc8
icu4j-eclipse-3.6.1-1jpp.3.fc8
eclipse-platform-3.3.0-30.fc8
> - which java
[marc@Strike-Lap ~]$ which java
/usr/bin/java
[marc@Strike-Lap ~]$
> - readlink -f `which java`
> 
[marc@Strike-Lap ~]$ readlink -f `which java`
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/bin/java
[marc@Strike-Lap ~]$

Comment 1 Andrew Overholt 2008-01-08 14:01:19 UTC
I can't duplicate this problem.  Are you getting hs_* files in the directory
from which you've run Eclipse?

Try running with -consolelog -debug and see if you get anything on the console.

Tom, have you seen anything like this?  Note that he doesn't have subclipse
installed which I believe your other crasher did have.

Comment 2 Marc Wiriadisastra 2008-01-08 14:12:12 UTC
Created attachment 291053 [details]
Output from running Starting application: 1219
!SESSION 2008-01-08 23:06:02.997 -----------------------------------------------
Output from running the -consolelog and -debug

That is the output I get.

Comment 3 Marc Wiriadisastra 2008-01-08 14:13:30 UTC
No hs-* files at all I get those with netbeans which fails to even load I'm not
to sure if that would help but if so I can upload the netbeans log.

Comment 4 Andrew Overholt 2008-01-08 14:17:29 UTC
This really looks like a JVM issue.  Can you try it with another JVM? 
java-gcj-compat will work but I'm more interested in results with a Sun VM.

Comment 5 Marc Wiriadisastra 2008-01-08 14:20:26 UTC
As in try with Sun's JRE?

Comment 6 Andrew Overholt 2008-01-08 14:25:40 UTC
(In reply to comment #5)
> As in try with Sun's JRE?

Yes, please.  If you can.

Comment 7 Marc Wiriadisastra 2008-01-08 21:29:57 UTC
Created attachment 291090 [details]
Output using Sun's JRE

Comment 8 Marc Wiriadisastra 2008-01-08 21:31:01 UTC
Created attachment 291091 [details]
error log from eclipse

I still doesn't show that I have java on the java page for some reason so that
may be the reason.

Comment 9 Andrew Overholt 2008-01-15 15:34:48 UTC
No, the JVM just needs to be set up properly in
Window->Preferences->Java->Installed JREs.  I think this looks like an IcedTea
bug.  I'll re-assign there for now.

Comment 10 Lillian Angel 2008-02-04 19:30:19 UTC
I can't reproduce this at all. I tested this with a few versions of IcedTea and
OpenJDK.

Comment 11 Lillian Angel 2008-02-04 19:32:54 UTC
(In reply to comment #7)
> Created an attachment (id=291090) [edit]
> Output using Sun's JRE
> 

It looks like it is seg faulting with Sun's JRE as well. This is not an IcedTea
bug... I suspect something is wrong with a different interfering package

Comment 12 Marc Wiriadisastra 2008-02-04 21:37:56 UTC
You are right it is something wrong with my system. I actually re-installed the
yesterday and it works fine.

Netbeans works fine with icedtea as well so I was going to close this bug as
notabug but something dumb in my previous system that I had done.




Note You need to log in before you can comment on or make changes to this bug.