Bug 428021 - evolution-debuginfo missing files?
evolution-debuginfo missing files?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 13:46 EST by Brian Long
Modified: 2008-01-08 15:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 15:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Long 2008-01-08 13:46:35 EST
Description of problem:
I am trying to diagnose why Evolution is freezing while I type messages.  I
installed various packages:
evolution-2.12.2-2.fc8
evolution-data-server-1.12.2-1.fc8
evolution-data-server-debuginfo-1.12.1-2.fc8
evolution-data-server-devel-1.12.2-1.fc8
evolution-debuginfo-2.12.1-3.fc8
evolution-help-2.12.2-2.fc8
evolution-webcal-2.12.0-1.fc8
evolution-webcal-debuginfo-2.12.0-1.fc8
glib2-debuginfo-2.14.2-1.fc8
gtk2-debuginfo-2.12.1-5.fc8
gtkhtml3-debuginfo-3.16.1-1.fc8
NetworkManager-debuginfo-0.7.0-0.6.6.svn3138.fc8
pango-debuginfo-1.18.3-1.fc8

If I run "gdb evolution" it complains as follows:
warning: the debug information found in
"/usr/lib/debug//usr/bin/evolution.debug" does not match "/usr/bin/evolution"
(CRC mismatch).

warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/80/db6781dbac86f5c2d7da79e5f7e51ae0d6f42d.debug
(no debugging symbols found)

Is evolution-debuginfo faulty or am I missing something simple?
Comment 1 Brian Long 2008-01-08 13:58:10 EST
So I failed to enable updates-debuginfo when I installed the debuginfo packages.
 Shouldn't the -debuginfo packages require an exact version of their
corresponding base package?   For example, evolution-debuginfo-2.12.2-2.fc8
should require: evolution-2.12.2-2.fc8.  This would avoid the simple mistake I
made.  :-)
Comment 2 Matthew Barnes 2008-01-08 15:00:42 EST
SPEC files generally do not have explicit requirements for their own debuginfo
packages.  RPM automates that whole process through its macros, which are
defined in the redhat-rpm-config package and apply to all packages.

I'm told the reason for the lack of an exact version requirement in the
debuginfo packages is to allow you to disable your debuginfo repo and update
your system without forcing you to first remove all your debuginfo packages. 
The problem is we don't really have an automated way of garbage collecting
obsolete debuginfo packages that are just taking up space on one's system.

In any case, this is beyond the scope of the Evolution packages so I'm going to
close this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.