Bug 428086 - CUPS performance regression
CUPS performance regression
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.1
All Linux
high Severity medium
: rc
: ---
Assigned To: Tim Waugh
: Regression
Depends On:
Blocks: 391501
  Show dependency treegraph
 
Reported: 2008-01-09 00:28 EST by Norm Murray
Modified: 2009-08-18 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:57:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norm Murray 2008-01-09 00:28:22 EST
In RHEL 4 we'd added a custom feature to aid printing performance in relation to
fetching a list of queues from a remote server and validating the queue once
selected. 

Customer is reporting that RHEL 5 printing performance had dropped relative to
the current RHEL 4 version. 

Customer only uses lp (not lpr) for job submission and always specifies a
destination. Cups host is usually set through the CUPS_SERVER environment
variable, but sometimes (10%) passed with the -h option on the command line. 

Targeted print threshold time is about 700ms (current using a custom built cups
lp binary on a RHEL 2.1 system), current performance on RHEL 5.1 is about 2
seconds. With 100k print jobs a day,
Comment 1 RHEL Product and Program Management 2008-01-09 00:56:52 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Tim Waugh 2008-01-09 05:24:23 EST
The solution will be to use the same method as cups-lpd to submit jobs when the
destination is known.
Comment 16 errata-xmlrpc 2009-01-20 16:57:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html

Note You need to log in before you can comment on or make changes to this bug.