Bug 428150 - Pulseaudio crashes and can't be restarted
Pulseaudio crashes and can't be restarted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 12:06 EST by Need Real Name
Modified: 2008-02-28 13:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 13:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-01-09 12:06:29 EST
Description of problem:
Every once in a while when running an audio application, pulseaudio sound
crashes given me a continued buzzing or clicking sound.
The only way to stop the sound is to kill the pulseaudio process.

Then, when I restart the pulseaudio process, I get a slew of errors (see below)
and no sound. Logging out and in again doesn't help and nor does killing the
X-server or going down to init3 and back up to init5.

However, at all times system-config-soundcard still detects my sound devices
properly and the sound test itself still works showing that this is most likely
a pulseaudio problem or at least a higher level sound problem.

The only way I can get pulseaudio sound working again is to reboot!!!

Even if you can't identify the source of the initial crash, I would like to
figure out how I can restart pulseaudio without having to reboot since rebooting
in the Linux environment is unacceptable except in order to swap hardware or
after kernel upgrades.


Here is the output from running pulseaudio:

ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:3: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:3
source_name=alsa_input.pci_109e_878_alsa_capture_0"): initialization failed.
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:2: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:2
source_name=alsa_input.pci_14f1_8801_alsa_capture_0"): initialization failed.
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_24c5_alsa_playback_0"): initialization failed.
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_8086_24c5_alsa_capture_0"): initialization failed.

Note that my sound devices are numbered as follows
   0 Intel Corporation 82801DB/DBL/DBM (ICH$/ICH$-L/ICH4-M) [this is my main
integrated motherboard sound chip on my p4pe motherboard]

   1 PNPb006 PNPb006 [I believe this is the MIDI chip on the motherboard]
 
   2 Conexant CX8801 [This is the sound device on my pchdtv 5500 card]

   3 Brooktree Bt878 [This is the sound device on my Winfast 2000XP analog tv card]

Here is the full output from running pulseaudio -vv:

I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_109e_878_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:3
source_name=alsa_input.pci_109e_878_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:3: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:3
source_name=alsa_input.pci_109e_878_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_109e_878_alsa_capture_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:2
source_name=alsa_input.pci_14f1_8801_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:2: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:2
source_name=alsa_input.pci_14f1_8801_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_14f1_8801_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_playback_4
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_capture_3
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_capture_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0
sink_name=alsa_output.pci_8086_24c5_alsa_playback_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0
sink_name=alsa_output.pci_8086_24c5_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0
source_name=alsa_input.pci_8086_24c5_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0
source_name=alsa_input.pci_8086_24c5_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_109e_878_alsa_control__1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_14f1_8801_alsa_control__1
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_24c5_alsa_control__1
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #7; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-gconf.so': success
D: module-gconf.c: Loading module 'module-native-protocol-tcp' with args '' due
to GConf configuration.
I: protocol-native.c: using already loaded auth cookie.
I: protocol-native.c: using already loaded auth cookie.
I: module.c: Loaded "module-native-protocol-tcp" (index: #8; argument: "").
D: module-gconf.c: Loading module 'module-esound-protocol-tcp' with args '' due
to GConf configuration.
I: module.c: Loaded "module-esound-protocol-tcp" (index: #9; argument: "").
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired





Version-Release number of selected component (if applicable):


How reproducible:
Random -- so difficult to reproduce

-------------------------------------------------

As an editorial note, IMHO, pulseaudio is far from ready for release. It seems 
to be flakey, does not yet support a good range of programs, and has given users
a disproportionate share of trouble. At a minimum, it should have been phased in
more gradually.
Comment 1 Need Real Name 2008-01-09 13:03:10 EST
OK - figured out why pulseaudio wasn't restarting - the ConsoleKit service had
stopped and I needed to restart it AND log back in to make sound permissions
work again.

I'm not sure how to track down the root cause bug since I don't know what caused
it. However, I still think that sound (and pulseaudio in particular) are much
more unstable on FC8 than on previous versions. I don't remember ever getting
crashes like this except in the early alsa testing days.

Also, the fixes such as restarting ConsoleKit or haldaeomon or messagebus etc.
are non-obvious to most users. It would be nice to have this posted clearly
somewhere so that users don't waste hours of time figuring out what is wrong.

Thanks (and sorry for the griping -- I'm just major-league frustrated with sound
on FC8)
Comment 2 Lubomir Kundrak 2008-02-28 13:26:56 EST
ConsoleKit shouldn't have crashed in the first place. It should _never_ get
restarted. See your logs for possible cause.

Note You need to log in before you can comment on or make changes to this bug.