Bug 428177 - zd1211rw_mac80211 module missing
zd1211rw_mac80211 module missing
Status: CLOSED DUPLICATE of bug 426917
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 15:05 EST by Tomi Hautakoski
Modified: 2008-01-09 15:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 15:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomi Hautakoski 2008-01-09 15:05:50 EST
Description of problem:
After upgrading from the original Livecd setup to the latest updates, my
zd1211rw A-Link WLAN card stopped working. There's nothing in the dmesg about
the driver and seems like the module is missing from the new kernel rpm:

[tomppa@localhost ~]$ rpm -q kernel
kernel-2.6.23.1-42.fc8
kernel-2.6.23.9-85.fc8
[tomppa@localhost ~]$ rpm -ql kernel-2.6.23.1-42.fc8|grep zd1211rw-mac80211
/lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/zd1211rw-mac80211
/lib/modules/2.6.23.1-42.fc8/kernel/drivers/net/wireless/zd1211rw-mac80211/zd1211rw-mac80211.ko
[tomppa@localhost ~]$ rpm -ql kernel-2.6.23.9-85.fc8|grep zd1211rw-mac80211
[tomppa@localhost ~]$ 

Version-Release number of selected component (if applicable):
kernel-2.6.23.9-85.fc8

How reproducible:

Steps to Reproduce:
1. Install FC
2. Run 'yum update'
3. Boot and the card is not found anymore
  
Actual results:
Un-recognized WLAN card

Expected results:
A working WLAN card.

Additional info:
With the older kernel, the logs are these:

phy0: Selected rate control algorithm 'simple'
zd1211rw_mac80211 1-3:1.0: phy0
usbcore: registered new interface driver zd1211rw_mac80211
zd1211rw_mac80211 1-3:1.0: firmware version 4725
zd1211rw_mac80211 1-3:1.0: zd1211b chip 0ace:1215 v4810 high 00-1a-9f AL2230_RF
pa0 g--NS
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:16:01:f2:3f:27
wlan0: RX authentication from 00:16:01:f2:3f:27 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:16:01:f2:3f:27
wlan0: RX AssocResp from 00:16:01:f2:3f:27 (capab=0x401 status=0 aid=2)
wlan0: associated
wlan0: switched to short barker preamble (BSSID=00:16:01:f2:3f:27)
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:16:01:8c:5e:0d
wlan0: RX authentication from 00:16:01:8c:5e:0d (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:16:01:8c:5e:0d
wlan0: RX AssocResp from 00:16:01:8c:5e:0d (capab=0x411 status=0 aid=1)
wlan0: associated
wlan0: RX WEP frame, but no key set
wlan0: no IPv6 routers present
Comment 1 Tomi Hautakoski 2008-01-09 15:15:44 EST
Bug #426917 could be caused by the same problem?
Comment 2 Jon Stanley 2008-01-09 15:30:42 EST

*** This bug has been marked as a duplicate of 426917 ***

Note You need to log in before you can comment on or make changes to this bug.