This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 428178 - compiz-fusion causes flikering while video rendering.
compiz-fusion causes flikering while video rendering.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz-fusion (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 15:09 EST by Adrin Jalali
Modified: 2008-01-11 12:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 16:10:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2008-01-09 15:09:38 EST
Description of problem:
Hi there, 
I have an Inspiron 6400 laptop with lspci output :
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822
SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 01)
03:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
(rev 0a)
03:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0b:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

and having : uname -rpi
2.6.23.9-85.fc8 i686 i386


and have these packages installed :
compiz-all-0.6.99-8.fc8 and dependencies,
xorg-x11-server-Xorg-1.3.0.0-9.fc7

and have this :
yum -d 0 list kmod-fglrx
Installed Packages
kmod-fglrx.i686                          8.443.1-1.7.12.lvn8    installed       
Available Packages
kmod-fglrx.i586                          8.443.1-1.7.12.lvn8    livna

and when I disable compiz-fusion, everything is ok and I can watch video, but as
soon as I enable compiz-fusion, opening any video with any application, will
make part os screen showing video, fliker a lot that I can't see that video.

Note that I downgraded my server-Xorg to make compiz-fusion work, otherwise it
wouldn't work with my video card.
Comment 1 Adel Gadllah 2008-01-09 16:10:58 EST
I am sorry but you are using a binary driver and a third party package so there
is no way we can fix this bug.
You have to either reproduce it with the package in fedora + a free driver or
contact the packager/driver vendor.
In this case I suspect driver issues so please try contact AMD/ATI.
(If there is a textured video option you might want to try it).
Comment 2 Adrin Jalali 2008-01-10 02:26:58 EST
If it's the driver problem, so why when I disable compiz-fusion, everything
become ok?
Comment 3 Adel Gadllah 2008-01-10 10:49:57 EST
(In reply to comment #2)
> If it's the driver problem, so why when I disable compiz-fusion, everything
> become ok?

because using a compositing manager is a big difference for the driver. The non
compositing use case is the traditional one and therefore well tested and
mature. While compisting can lead to problems with some drivers.
Comment 4 Adrin Jalali 2008-01-11 12:26:48 EST
So what do you suggest me to use for my VGA card ? I tried so much drivers but
only this combination of packages worked. You mean I must wait for better
drivers, or change my laptop ?

Note You need to log in before you can comment on or make changes to this bug.