Bug 428180 - Traceback when adding zFCP disk without specifying details
Traceback when adding zFCP disk without specifying details
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
s390x Linux
low Severity low
: rc
: ---
Assigned To: Martin Sivák
Brock Organ
:
: 427839 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 15:25 EST by James Laska
Modified: 2013-09-02 02:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0397
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback.txt (30.15 KB, text/plain)
2008-01-09 15:25 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2008-01-09 15:25:28 EST
Description of problem:

While testing bug#248447, it was discovered that you can trigger a traceback
when adding a zFCP device with no details.  It looks like anaconda is trying to
pop-up a dialog noting no details were provided ... but it tracebacks due to
incorrect args to a gtk function

Version-Release number of selected component (if applicable):

RHEL-5-Server/U1 - anaconda-11.1.2.87-1

How reproducible:

100%


Steps to Reproduce:

At the Disk prompt, 
 1) Add another storage device
 2) Select zFCP
 3) Click Add (without entering disk details).
  
Actual results:
traceback


Expected results:
Dialog noting incorrect user-entered data


Additional info:
Comment 1 James Laska 2008-01-09 15:25:28 EST
Created attachment 291196 [details]
traceback.txt
Comment 2 Chris Lumens 2008-01-10 12:23:59 EST
diff --git a/iw/autopart_type.py b/iw/autopart_type.py
index 47d57f1..59f8eea 100644
--- a/iw/autopart_type.py
+++ b/iw/autopart_type.py
@@ -190,7 +190,7 @@ class PartitionTypeWindow(InstallWindow):
             try:
                 self.anaconda.id.zfcp.addFCP(devnum, wwpn, fcplun)
             except ValueError, e:
-                self.intf.messageWindow(_("Error"), e)
+                self.intf.messageWindow(_("Error"), "%s" % e)
                 continue
             break
 
Comment 10 errata-xmlrpc 2008-05-21 11:32:40 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0397.html
Comment 11 Radek Vykydal 2008-06-19 04:10:34 EDT
*** Bug 427839 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.