Bug 428192 - XClip does not support non-ascii characters
Summary: XClip does not support non-ascii characters
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xclip   
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-09 20:45 UTC by Leo
Modified: 2008-01-15 23:05 UTC (History)
0 users

Fixed In Version: 0.10-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 22:55:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leo 2008-01-09 20:45:04 UTC
Description of problem:

I've been a user of xclip for some time and have just found out that it
does not support any non-ascii characters. For example if you select
some non-ascii characters and then run xclip -o in the shell, you'll get
gibberish output.

For example,

,----[ Text in firefox ]
| « is the popular shorthand
`----

,----[ xclip -o ]
| � is the popular shorthand
`----


Version-Release number of selected component (if applicable):
xclip-0.10-1.fc8

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom "spot" Callaway 2008-01-14 20:56:22 UTC
Enabled utf8 mode as the default in xclip-0.10-2.

Thanks for the bugreport.

Comment 2 Leo 2008-01-15 09:09:33 UTC
It works. Thanks.

Comment 3 Fedora Update System 2008-01-15 22:55:35 UTC
xclip-0.10-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2008-01-15 23:05:05 UTC
xclip-0.10-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.