Bug 428201 - rc.sysinit calls commands that no longer exist or with bad arguments.
rc.sysinit calls commands that no longer exist or with bad arguments.
Status: CLOSED DUPLICATE of bug 428202
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
5.0
All Linux
low Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 16:50 EST by Sean Kelly
Modified: 2008-01-25 15:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 15:51:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Kelly 2008-01-09 16:50:07 EST
Description of problem:

In my attempt to create a VMware template RHEL5 system, I created a system that, on boot, runs 
through firstboot-tui and also all the things that rc.sysinit runs when it finds an /.unconfigured file. In 
doing so, I discovered two issues in rc.sysinit:

1. On line 738, it calls /usr/sbin/netconfig. netconfig has been deprecated in favor of 
/usr/sbin/system-config-network-tui from what I've found. On a different note, system-config-
network doesn't configure the hsotname whereas netconfig used to. Therefore, I'm not sure how to get 
the hostname reset properly.

2. On line 789, rc.sysinit calls `/usr/sbin/authconfig --nostart`. This results in authconfig outputting 
usage information. From the output, it appears that it should be calling `/usr/sbin/authconfig --
nostart --update` or something. One of --update, --test, or --probe should be being supplied to 
authconfig.

Version-Release number of selected component (if applicable): 8.45.17.EL-1


How reproducible: 100%

Steps to Reproduce:
1. Run /usr/sbin/sys-unconfig to create a /.unconfigured
2. After sys-unconfig halts system, boot system again.
3. Observe error message from authconfig before ntsysv starts. View terminal history to see it.
4. Note that no network configuration comes up since rc.sysinit looks for netconfig but system-config-
network-tui is the tool that is present nowadays.
  
Actual results:

1. Authconfig outputs usage and then quickly gets hidden by output of ntsysv
2. No network configuration utility is run.

Expected results:

1. Authconfig is run and the user is prompted how users should be authenticated.
2. system-config-network runs and assists with network configuration.


Additional info:
Comment 1 Bill Nottingham 2008-01-25 15:51:43 EST

*** This bug has been marked as a duplicate of 428202 ***

Note You need to log in before you can comment on or make changes to this bug.