This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 428238 - Printing failed for all Indic languages except Malayalam and Tamil language
Printing failed for all Indic languages except Malayalam and Tamil language
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 03:19 EST by Parag Nemade
Modified: 2008-11-11 02:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 02:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
printout of www.bbc.co.uk/hindi (2.00 MB, application/postscript)
2008-01-10 06:21 EST, Matěj Cepl
no flags Details
screenshot of www.bbc.co.uk/hindi (409.54 KB, image/png)
2008-01-10 06:24 EST, Matěj Cepl
no flags Details
correct version of the attachment (409.54 KB, image/png)
2008-01-10 06:27 EST, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 409828 None None None Never

  None (edit)
Description Parag Nemade 2008-01-10 03:19:12 EST
Description of problem:
Webpages displaying text in Indic languages are failing to print.


Version-Release number of selected component (if applicable):
firefox-3.0-0.beta2.8.fc9

How reproducible:
always

Steps to Reproduce:
1.Open Indic webpages http://bn.wikipedia.org or http://hi.wikipedia.org or
http://pa.wikipedia.org or http://www.bbc.co.uk/hindi/ or
http://www.bbc.co.uk/bengali/
2. print webpage to File or printer
3.
  
Actual Results:  
printed ps file failed to open in evince on rawhide
printed webpages resulted blank or some garbage text.

Expected Results:  
It should print any Indic webpage correctly.
It should open any ps("Print to File" option output) file.


Additional info:
Working fine for Malayalam and Tamil language.

Upstream Bug:- https://bugzilla.mozilla.org/show_bug.cgi?id=409828
Comment 1 Parag Nemade 2008-01-10 03:31:53 EST
For hindi wikipedia page when printed page to hi.ps and tried to open with
evince, I got following on console.
evince ../hi.ps =>

Error: /undefined in if11
Operand stack:
   false   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1909   1   3   %oparray_pop   1908
  1   3   %oparray_pop   1892   1   3   %oparray_pop   1771   1   3  
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1148/1684(ro)(G)--   --dict:0/20(G)--   --dict:81/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.61: Unrecoverable error, exit code 1

** (evince:31160): WARNING **: Interpreter failed.

(evince:31160): GLib-WARNING **: Error flushing string: Broken pipe
Error: /undefined in if11
Operand stack:
   false   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1909   1   3   %oparray_pop   1908
  1   3   %oparray_pop   1892   1   3   %oparray_pop   1771   1   3  
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1148/1684(ro)(G)--   --dict:0/20(G)--   --dict:81/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.61: Unrecoverable error, exit code 1

** (evince:31160): WARNING **: Interpreter failed.

(evince:31160): GLib-WARNING **: Error flushing string: Broken pipe
Comment 2 Matěj Cepl 2008-01-10 06:21:03 EST
Created attachment 291265 [details]
printout of www.bbc.co.uk/hindi

Yes, I can reproduce this pretty well. Attached is printout of
http://www.bbc.co.uk/hindi/, which when run with plain gs gives this output:

[matej@hubmaier ~]$ gs print.ps 
GPL Ghostscript 8.61 (2007-11-21)
Copyright (C) 2007 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Error: /rangecheck in --xyshow--
Operand stack:
   (\002\035\036\002)	--nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--	--nostringval--  
--nostringval--   2   %stopped_push   --nostringval--	--nostringval--  
--nostringval--   false   1   %stopped_push   1905   1	 3   %oparray_pop  
1904   1   3   %oparray_pop   1888   1	 3   %oparray_pop   1771   1   3  
%oparray_pop   --nostringval--	 %errorexec_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2	%stopped_push	--nostringval--
Dictionary stack:
   --dict:1143/1684(ro)(G)--   --dict:0/20(G)--   --dict:86/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 292591
GPL Ghostscript 8.61: Unrecoverable error, exit code 1
[matej@hubmaier ~]$ 

Doesn't look good.
Comment 3 Matěj Cepl 2008-01-10 06:24:53 EST
Created attachment 291267 [details]
screenshot of www.bbc.co.uk/hindi

Do I need to have some additional packages installed? It seems to me that
www.bbc.co.uk/hindi displays well (of course, I have no clue whether it is true
or not).
Comment 4 Matěj Cepl 2008-01-10 06:27:30 EST
Created attachment 291268 [details]
correct version of the attachment

somehow the hindi in the filename was too much for firefox (or bugzilla)?
Comment 5 Parag Nemade 2008-01-10 06:32:00 EST
Thanks for your reply here.
  afaics, rendering in those pages are good. Webpages are displayed correctly
with currect rawhide firefox package.
  I dunno whose problem is this cairo/postscript or firefox 3 printing module.
So right now reported against firefox component only.
Comment 6 Behdad Esfahbod 2008-01-10 13:04:40 EST
It's most prolly caused by a bug in cairo's PS/PDF backends with bitmap fonts. 
Is that the case?
Comment 7 Parag Nemade 2008-02-11 05:04:35 EST
Tested with firefox-3.0-0.beta2.15.nightly20080130.fc9
Looks printing problem is now resolved.
Comment 8 Bug Zapper 2008-05-14 00:22:03 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Tony Fu 2008-09-09 23:16:53 EDT
requested by Jens Petersen (#27995)

Note You need to log in before you can comment on or make changes to this bug.