Bug 428271 - gurlchecker: please rebuild for new clamav
gurlchecker: please rebuild for new clamav
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gurlchecker (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arindam Ghosh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 07:52 EST by Tomas Hoger
Modified: 2008-01-22 10:55 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.10.1-5.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:35:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2008-01-10 07:52:04 EST
Upstream clamav 0.92 introduced a soname change (libclamav.so.2 ->
libclamav.so.3).  Clamav updates are available in F7 and F8 testing.

Please rebuild your package.
Comment 1 Mamoru TASAKA 2008-01-10 09:34:23 EST
Currently on F-7:

$ koji latest-pkg dist-fc7-build clamav
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
clamav-0.91.2-3.fc7                       dist-fc7-updates      spot
Comment 2 Tomas Hoger 2008-01-10 10:10:09 EST
It's currently only in testing repository.  You should be able to build in
-updates-testing or -updates-candidate.
Comment 3 Mamoru TASAKA 2008-01-10 10:23:57 EST
$ koji list-targets --name dist-fc7-updates-candidate
Name                           Buildroot                      Destination      
            
---------------------------------------------------------------------------------------------
dist-fc7-updates-candidate     dist-fc7-build                
dist-fc7-updates-candidate    

So build targeted at dist-fc7-updates-candidate uses dist-fc7-build Buildroot,
on which clamav 0.92 is not available. 

Also:
$ koji list-targets --name dist-fc7-updates-testing
Name                           Buildroot                      Destination      
            
---------------------------------------------------------------------------------------------
We cannot rebuild against "dist-fc7-updates-testing" target.
What I mean is that we cannot use packages in "dist-fc7-updates-testing"
but can packages in "dist-fc7-build". Ask rel-eng team to add
clamav-0.92-6.fc7 to buildroot.


Comment 4 Arindam Ghosh 2008-01-10 11:07:17 EST
yeah! i think we should wait until clamav-0.92-6 becomes stable
Comment 5 Tomas Hoger 2008-01-11 03:28:06 EST
Sorry guys, I got confused, as I've seen some F8 builds correctly link against
new libclamav.  Actually, F8 buildroot already has new clamav:

$ koji latest-pkg dist-f8-build clamav
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
clamav-0.92-6.fc8                         dist-f8-override      ensc
Comment 6 Tomas Hoger 2008-01-11 10:24:29 EST
Now in F7 buildroot too:

$ koji latest-pkg dist-fc7-build clamav
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
clamav-0.92-6.fc7                         dist-fc7-override     ensc
Comment 7 Mamoru TASAKA 2008-01-13 12:52:59 EST
Rebuild against clamav 0.92 done:

gurlchecker-0.10.1-5.fc8.1
gurlchecker-0.10.1-5.fc7.1
Comment 8 Arindam Ghosh 2008-01-15 11:51:30 EST
Mamuro, thanks for rebuilding the package (was somewhat busy)....i will put up
the  upstream version of gurlchecker shortly :)
Comment 9 Arindam Ghosh 2008-01-15 11:52:11 EST
Mamoru, thanks for rebuilding the package (was somewhat busy)....i will put up
the  upstream version of gurlchecker shortly :)
Comment 10 Fedora Update System 2008-01-15 17:58:18 EST
gurlchecker-0.10.1-5.fc7.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gurlchecker'
Comment 11 Fedora Update System 2008-01-15 18:05:03 EST
gurlchecker-0.10.1-5.fc8.1 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gurlchecker'
Comment 12 Fedora Update System 2008-01-22 10:35:12 EST
gurlchecker-0.10.1-5.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-01-22 10:55:20 EST
gurlchecker-0.10.1-5.fc8.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.