Bug 428278 - top does not properly honor .toprc field displays
top does not properly honor .toprc field displays
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.8
All Linux
low Severity low
: rc
: ---
Assigned To: Tomas Smetana
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 08:32 EST by Adam Stokes
Modified: 2012-09-25 08:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0706
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch... (549 bytes, patch)
2008-01-10 09:30 EST, Tomas Smetana
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-01-10 08:32:39 EST
Description of problem:
Changing field displays and writing them to .toprc are incorrectly read during 
next load.

Version-Release number of selected component (if applicable):
procps 3.2.3-8.9

How reproducible:
100%

Steps to Reproduce:
1. Start top
2. press 'f'
3. press 'K' to remove CPU field
4. write toprc
5. reload top to  find cpu field visible
  
Actual results:
toprc is not read properly

Expected results:
toprc be read correctly

Additional info:
This problem is introduced only in RHEL4 because of RFE 
https://bugzilla.redhat.com/show_bug.cgi?id=240363

F8, RHEL5 do not show this problem as this patch does not seem to be present.

Thanks
Comment 1 Tomas Smetana 2008-01-10 09:30:42 EST
Created attachment 291280 [details]
The patch...

Here's the patch that seems to solve the problem.
Comment 6 Issue Tracker 2008-01-10 10:18:34 EST
Tomas,

after having rebuilt a test package included your patch I can confirm the
issue is fixed.

Thanks,

Sebastien.


This event sent from IssueTracker by saime 
 issue 137134
Comment 7 RHEL Product and Program Management 2008-01-11 08:35:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 22 errata-xmlrpc 2008-07-24 15:53:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0706.html

Note You need to log in before you can comment on or make changes to this bug.