Bug 428301 - [GS Cert] System-config-user hangs when numerical group name is trying to be added. - Regression
[GS Cert] System-config-user hangs when numerical group name is trying to be ...
Status: CLOSED DUPLICATE of bug 427504
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-users (Show other bugs)
5.1
All Linux
high Severity high
: rc
: ---
Assigned To: Nils Philippsen
: Regression
Depends On:
Blocks: 246139 250607 296411
  Show dependency treegraph
 
Reported: 2008-01-10 11:49 EST by Alan Matsuoka
Modified: 2008-04-02 06:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 06:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Matsuoka 2008-01-10 11:49:30 EST
Description of problem:
Whenever I tried to create user, the application(system-config-users) looks hung
up. (The program will hang or will go into infinitive wait.)


Version-Release number of selected component (if applicable):
system-config-users-1.2.51-3.el5.noarch.rpm

How reproducible:

Whenever I tried to create user, the application(system-config-users) looks hung
up. (The program will hang or will go into infinitive wait.)



  
Actual results:


Expected results:


Additional info:
I don't have enough time to wait.
The GS Certification deadline is almost over.
Hope your rapid reponse.

oll(Traceback (most recent call last):
 File "/usr/share/system-config-users/userWindow.py", line 354, in
on_userWin_ok_button_clicked
   groupEnt.set (libuser.GROUPNAME, groupName)
NameError: global name 'groupName' is not defined

above is last part of strace that syang has captured.
Comment 2 RHEL Product and Program Management 2008-01-17 10:26:08 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Oleg L. Sadov 2008-04-01 11:44:28 EDT
Seems like a coding error -- 'groupName' is not defined variable in
userWindow.py. May be fixed by this patch:

--- system-config-users-1.2.51/src/userWindow.py.orig   2008-04-01
17:59:41.000000000 +0400
+++ system-config-users-1.2.51/src/userWindow.py        2008-04-01
18:02:10.000000000 +0400
@@ -351,7 +351,7 @@
                 #No group currently exists with this name, so we can create one
                 groupEnt = self.parent.ADMIN.initGroup(userName)
                 # workaround bug with purely numerical names in ADMIN.initGroup ()
-                groupEnt.set (libuser.GROUPNAME, groupName)
+                groupEnt.set (libuser.GROUPNAME, userName)
                 groupEnt.set (libuser.GIDNUMBER, gidNumber)
                 cn = groupEnt.get(libuser.GROUPNAME)[0]
Comment 4 Nils Philippsen 2008-04-02 04:50:27 EDT
(In reply to comment #3)
> Seems like a coding error -- 'groupName' is not defined variable in
> userWindow.py.

This is already fixed in the upstream Fedora packages, but we don't have the
proper flags for integrating this in the RHEL-5 packages.
Comment 6 RHEL Product and Program Management 2008-04-02 05:13:25 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 7 Nils Philippsen 2008-04-02 06:50:58 EDT
Ahh, my bad -- this bug has been reported already and fixed in
system-config-users-1.2.51-4.el5. Sorry for the confusion.

*** This bug has been marked as a duplicate of 427504 ***

Note You need to log in before you can comment on or make changes to this bug.