Bug 42833 - video module doesn't load at startup
Summary: video module doesn't load at startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-30 11:42 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-12 17:20:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested config file (1.77 KB, text/plain)
2001-06-01 10:58 UTC, Need Real Name
no flags Details
requested lspci output (5.03 KB, text/plain)
2001-06-01 11:00 UTC, Need Real Name
no flags Details
requested XFree86.0.log (deleted)
2001-06-01 11:02 UTC, Need Real Name
no flags Details
requested XFree86.0.log (deleted)
2001-06-01 11:04 UTC, Need Real Name
no flags Details
requested XFree86.0.log (deleted)
2001-06-01 11:06 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-05-30 11:42:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
 module agpgart doesn't automatically load at start. If not modprobed then 
when processors (2)are exercised the Xscreen goes blank. If modprobed and 
processors exercised vertical hold jumps and sticks at about a 1/4 screen 
wrap??

How reproducible:
Always

Steps to Reproduce:
1.upgrade from 7.0 to 7.1
2.lsmod if agpgart not present then exercise processor(s)
3.modprobe and exercise processor(s) for vertical hold jump
	

Actual Results:  see description

Expected Results:  agpgart should load automatically at start up and X 
should remain stable

Additional info:

ati All-in Wonder pro video card w/8Mb

Comment 1 Arjan van de Ven 2001-05-30 14:59:12 UTC
Mike: can we reproduce this ?

Comment 2 Alan Cox 2001-05-30 15:00:12 UTC
All-in-wonder pro or All-in-wonder pro 128 ?
Can you attach the log file X creates on startup (/var/log/XFree86.0.log) and
lspci -vv output.

Alan


Comment 3 Mike A. Harris 2001-05-31 05:12:11 UTC
I can't reproduce it.  I need the info Alan requested though..
Also the XF86Config-4 file.  Please attach them using the link below.
I have an AIW r128 pro.  I'm guessing the non 128 pro card is Mach 64 based.
If so, it should be configured with:

Xconfigurator --preferxf4 --nodri

Can you please supply the requested info uisng the link below?  Thanks.

Comment 4 Mike A. Harris 2001-05-31 05:24:29 UTC
I was trying on an All in Wonder 128 Pro..  I just looked through the pile
of ATI boxes here and found an AIW Pro 8Mb PCI.  Is the card you have PCI
or AGP?

Comment 5 Need Real Name 2001-06-01 10:58:01 UTC
Created attachment 20076 [details]
Requested config file

Comment 6 Need Real Name 2001-06-01 11:00:33 UTC
Created attachment 20077 [details]
requested lspci output

Comment 7 Need Real Name 2001-06-01 11:10:53 UTC
the card is an AGP

Comment 8 Need Real Name 2001-06-01 11:47:06 UTC
After attaching the requested files I ran Xconfigurator --preferfx4 --nodri as 
indicated that the AIW Mach64 based card should be configured with. The after 
reconfiguration results match remain unchanged.

Comment 9 Need Real Name 2001-06-04 11:03:39 UTC
Additional to description:

If I don't modprobe then either the screen goes blank.... or the system kicks 
me back to the log on screen. When this happens the screen first blinks a few 
times very similar to when Xconfigurator tests your settings.

Comment 10 Need Real Name 2001-10-15 11:23:52 UTC
I've backed my system off to RH 7.0 in June. Is there any new status on this 
report?

Comment 11 Need Real Name 2001-12-12 17:19:59 UTC
Is this issue corrected in RH 7.2    Please advise

Comment 12 Mike A. Harris 2002-02-11 13:42:00 UTC
Problem seems to be fixed when using Red Hat Linux 7.2 plus XFree86 4.2.0
and other dependant packages from rawhide, as I can't seem to reproduce it.
If you can still reproduce it with the new distro and rawhide updates,
please reopen the bug report, and attach new relevant details, and
logs+configs.


Note You need to log in before you can comment on or make changes to this bug.