Bug 428340 - Modules ieee1394 ... don't exist
Modules ieee1394 ... don't exist
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-10 17:58 EST by Rick Richardson
Modified: 2008-01-29 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 17:16:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2008-01-10 17:58:00 EST
$ modprobe ieee1394 raw1394 ohci1394 video1394
FATAL: Module ieee1394 not found.

http://dl.atrpms.net/all/ieee1394-kmdl-2.6.23.9-85.fc8-2.6.23.1-4.fc8.i686.rpm

Shouldn't this module exist in the Fedora distro?

I'm trying to get coriander (http://damien.douxchamps.net/ieee1394/coriander/)
to work to capture frames over ieee1394 from a Basler camera.
Comment 1 Chuck Ebbert 2008-01-10 18:22:51 EST
Didn't firewire-core and firewire-ohci work?
Comment 2 Rick Richardson 2008-01-10 18:43:51 EST
Don't know what "firewall-core" is.  Does it include modules so that:

# modprobe ieee1394 raw1394 ohci1394 video1394

works???
Comment 3 Rick Richardson 2008-01-10 18:47:35 EST
"The modules load, but coriander doesn't work (sees some
stuff about the camera, but doesn't work) I'll hook the camera
back up and see what the exact error message is.

All the coriander pages reference ieeexxx instead of firewire_xxx
(which did, indeed ship with the distro)

I just discovered that the ieeexxx stuff, done just like the
web pages, doesn't work worth shit either.

I've given up on the expensive camera and am now trying
to get one of two cheap webcams going to get some low-res
images."
Comment 4 Andrew Farris 2008-01-11 06:35:35 EST
Rick, what Chuck was saying is try loading the firewire_* modules instead of
ieee1394, *NOT* as a way to make your modprobe command work, but instead of.

# modprobe firewire_core firewire_ohci

For filesystems (but maybe not for your camera) you need to add:
# modprobe firewire_sbp2
Comment 5 Stefan Richter 2008-01-12 15:53:01 EST
See http://wiki.linux1394.org/Introduction and other pages at that wiki for
information on the various driver modules.  Since F7, Fedora has switched to the
new firewire-* drivers which replace the *1394 drivers.

I don't use Fedora myself, therefore am not sure how it works there, but modern
distros will automatically load either firewire-ohci + firewire-core or ohci1394
+ ieee1394 when a FireWire controller is detected during boot, depending on
which of the two driver stacks are installed.  Additional drivers will be
subsequently autoloaded when external FireWire devices are recognized.  With the
new drivers, you only need firewire-ohci + firewire-core for video capture.

If you have trouble running Coriander, please search the bugzilla whether there
are already respective entries.  There has been some bugfixing going on recently
and those entries might contain pointers to test packages with fixes.

In addition, the upstream libdc1394 v2 has been undergoing lots of changes
lately, and actually went from beta to release candidate to final release only
recently.  Likewise, Coriander barely kept up with the development of libdc1394
but a stabilized release which properly works with libdc1394 v2/final should be
out soon.  The F8 packages obviously can only contain release candidates of
libdc1394 v2 and Coriander right now, which might have quirks.  However, the
maintainers of the Fedora libdc1394 and Coriander packages as well as of the
kernel packages are aware of (and contributing to) the ongoing upstream
developments, so things should get into gears eventually.
Comment 6 Hans de Goede 2008-01-24 15:25:43 EST
As explainted in comment #5 there are 2 different firewirestacks, the old and
the new juju stack. The modules you are looking for are for the old stack
whereas Fedora uses the new juju stack.

Using idcc camera's with the new stack was broken until very recently, but its
fixed now, and all the necessary packages have very recently become available in
Fedora.

Ussing an up2date mirror, the following command should get you a working setup
(after a reboot for the new kernel):

yum --enablerepo=updates-testing install kernel libdc1394 coriander

This should install / update to the following versions of the involved components:
kernel-2.6.23.14-115.fc8
libdc1394-2.0.1-3.fc8
coriander-2.0.0-0.6.rc6.fc8

If you cannot get these from the update repo for one reason or the other here
are some links where you can download them from the buildsys:
http://koji.fedoraproject.org/koji/buildinfo?buildID=32352
http://koji.fedoraproject.org/koji/buildinfo?buildID=32168
http://koji.fedoraproject.org/koji/buildinfo?buildID=32170

Closing this, as this is fixed now, please reopen if coriander still doesn't
work for you.
Comment 7 Rick Richardson 2008-01-28 22:36:08 EST
Running the exact mix of revisions mentioned in the bugzilla
posting still does not work. Error message is the same:

libdc1394 warning: Could not open video1394 device file in /dev
libdc1394 error: Error: Could not free iso channel
libdc1394 warning: Warning: Could not free ISO channel
libdc1394 error: Error: Failed to setup DMA capture
Failed to setup capture. Error code -1

Restricting the memory to 1G (appending mem=1024M to boot args)
did not change the error at all.

dmesg shows:

firewire_core: created new fw device fw1 (0 config rom retries, S400)
firewire_core: phy config: card 0, new root=ffc0, gap_count=5

Sigh. But at least I'm running fc8 now :)

I tried the 2.6.24 kernel fresh from kernel.org too, no joy.
--
Comment 8 Hans de Goede 2008-01-29 07:07:11 EST
(In reply to comment #7)
> Running the exact mix of revisions mentioned in the bugzilla
> posting still does not work. Error message is the same:
> 
> libdc1394 warning: Could not open video1394 device file in /dev
> libdc1394 error: Error: Could not free iso channel
> libdc1394 warning: Warning: Could not free ISO channel
> libdc1394 error: Error: Failed to setup DMA capture
> Failed to setup capture. Error code -1
> 

Hmm, this sounds to me like you're using a non juju compiled libdc1394. Probably
a leftover of a previous experiment where you installed libdc1394 manually?

What does:
rpm --verify libdc1394 coriander
Say?

And what does
ldd /usr/bin/coriander
Say?
Comment 9 Rick Richardson 2008-01-29 17:16:17 EST
On Jan 29, 2008 11:27 AM, Andy Warner <andyw@pobox.com> wrote:
> > (s)he could be right. Got about a zillion versions of everything
> installed. Builds from source end up in /usr/local/{lib,bin}, stuff
> from rpms in /usr/{lib,bin} - will clean house and try again later.

That was, indeed the problem. Coriander is working now.

Now to see if I can strip it down or write a simple command line
app to take a snapshot and save it in some lossless format, like tiff.

Thanks for your gentle encouragement, I appreciate it.
--
Andy
Comment 10 Stefan Richter 2008-01-29 18:04:56 EST
> Now to see if I can strip it down or write a simple command line
> app to take a snapshot


I don't want to spoil the fun, but... have a look into the examples/ directory
of the libdc1394 sources.

Note You need to log in before you can comment on or make changes to this bug.