Bug 428431 - strange behavior with dogtail.rawinput.pressKey()
strange behavior with dogtail.rawinput.pressKey()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: at-spi (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Matthias Clasen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 09:04 EST by James Laska
Modified: 2013-09-02 02:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0469
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 508147 None None None Never

  None (edit)
Description James Laska 2008-01-11 09:04:46 EST
+++ This bug was initially created as a clone of Bug #410291 +++

Description of problem:
Originaly filed as:
http://bugzilla.gnome.org/show_bug.cgi?id=501286
The VNC viewer used to show a xen guest's console doesn't handle AT-SPI events
correctly.

Version-Release number of selected component (if applicable):
virt-viewer-0.0.2-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Use virt-install to start a Xen HVM (para virt should do as well) installation
2. Wait for the VNC console to appear
3. start python
3. use dogtail.rawinput.pressKey(':') which sould generate a key press event at
the VNC console
4. instead of colon ':' there appears a semi-colon ';'
  
Actual results:
VNC widget shows a semi-colon instead of colon

Expected results:
VNC widget shows the exact same characters as dogtail.rawinput instructs it to show.

Additional info:
Same behavior occurs with Fedora8/virt-viewer(GTK VNC widget) and
RHEL5/vncviewer(vnc package).

-- Additional comment from atodorov@redhat.com on 2007-12-04 08:06 EST --
I am still not sure if the bug is in the viewer or the underlying GTK/VNC widget.

-- Additional comment from mbabej@redhat.com on 2007-12-17 07:52 EST --
Xorg + vnc extension works for me. So i think this is vnc related issue.

-- Additional comment from berrange@redhat.com on 2007-12-17 09:05 EST --
Can you tell me what keymap you have configured on your local X desktop, what
keymap is configured inside the guest OS, and include the output of 'virsh
dumpxml [name of guest]' for the guest that you are trying to view.


-- Additional comment from atodorov@redhat.com on 2007-12-18 04:23 EST --
Created an attachment (id=289867)
virsh dumpxml output

> keymap configured inside the guest OS
I'm not sure how do I tell. I hit the bug when booting the installation media.

> keymap configured on your local X desktop
Same here. I don't remember doing some speciffic settings in my GNOME session. 

Which file should I look for that?

Additional info:
I've tried both when running GNOME and when running Xvnc without anything else
started. Hit the bug both times. 


-- Additional comment from mbabej@redhat.com on 2008-01-08 08:12 EST --
moving to at-spi component, since i'm pretty sure it's a bug in at-spi-registryd.

VNC server doesn't support XKB extension, and
at-spi-1.18.1/registryd/deviceeventcontroller.c 
contains this piece of code:


static gboolean
dec_lock_modifiers (SpiDEController *controller, unsigned modifiers)
{
        return XkbLockModifiers (spi_get_display (), XkbUseCoreKbd, 
                          modifiers, modifiers);
}


So locking any modifier keys doesn't work through VNC.

-- Additional comment from mbabej@redhat.com on 2008-01-10 10:10 EST --
provided a patch in the upstream bug, needs review though.

-- Additional comment from atodorov@redhat.com on 2008-01-10 11:05 EST --
Michal provided custom build rpms for RHEL 5.1 and I verified that his patches work.
Comment 2 RHEL Product and Program Management 2008-01-11 09:15:44 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Matthias Clasen 2008-01-11 09:21:44 EST
Michal, I don't see a patch in the upstream bug. 

Can you attach it there ? Or here. Or in both places...
Comment 5 RHEL Product and Program Management 2008-01-14 11:25:43 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 Alexander Todorov 2008-01-15 08:06:32 EST
(In reply to comment #3)
> Michal, I don't see a patch in the upstream bug. 
> 
> Can you attach it there ? Or here. Or in both places...
Patch is attached here:
http://bugzilla.gnome.org/show_bug.cgi?id=508147

Michal filed another BZ at GNOME's website.
Comment 7 Alexander Todorov 2008-01-15 08:13:28 EST
Tested and verified with provided at-spi package from Michal.
Other packages were standard RHEL5.1
Comment 9 Matthias Clasen 2008-01-16 22:18:24 EST
Built at-spi-1.7.11-3.el5 with the patch
Comment 11 Alexander Todorov 2008-04-02 05:49:59 EDT
Fails QA with:
at-spi-1.7.11-3.el5
dogtail-0.6.1-2.el5
virt-viewer-0.0.2-1.el5
Comment 13 Matthias Clasen 2008-04-02 11:26:38 EDT
Alex, can you provide more specifics than just "Fails QA" ?
Comment 18 errata-xmlrpc 2008-05-21 11:38:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0469.html

Note You need to log in before you can comment on or make changes to this bug.