Bug 428453 - RHEL4 to RHEL5.1 upgrade fails on gcc packages
RHEL4 to RHEL5.1 upgrade fails on gcc packages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 12:41 EST by Adam Stokes
Modified: 2011-01-24 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 16:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2008-01-11 12:41:41 EST
Description of problem:
Upgrade install from RHEL4.6 to RHEL5.1 fails to install /usr/lib/gcc* packages
with 'upgrade.log:error: unpacking of archive failed on file foo' messages.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Install 'everything' RHEL4Ux
2. Upgrade to RHEL5.1
3.
  
Actual results:
error: unpacking of archive failed on file
/usr/libexec/gcc/i386-redhat-linux/4.1.2: cpio: rename


Expected results:
cpio completes succesfully and package upgrade continues rather than skips.

Additional info:
This is due to a typo in gcc.spec that was coincidentally fixed in another BZ#
249384
Comment 1 RHEL Product and Program Management 2008-01-11 12:55:19 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Issue Tracker 2008-03-25 16:28:53 EDT
----- Additional Comments From mranweil@us.ibm.com (prefers email at
mjr@us.ibm.com)  2008-03-25 15:56 EDT -------
Red Hat - from an internal comment about snapshot 1:
Things are better... it seems that only a single package continues to have
the
cpio unpack error:

Upgrading libgcj - 4.1.2-41.el5.i386
error: unpacking of archive failed on file /usr/lib/gcj-4.1.2: cpio:
rename 


This event sent from IssueTracker by jkachuck 
 issue 141257
Comment 6 RHEL Product and Program Management 2008-06-02 16:25:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jakub Jelinek 2008-07-03 16:40:57 EDT
This has been fixed in RHEL4.7 gcc4 packages.

Note You need to log in before you can comment on or make changes to this bug.