Bug 428478 - /usr/share/info/dir.gz installed by mtools package
/usr/share/info/dir.gz installed by mtools package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtools (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-11 16:54 EST by Todd Zullinger
Modified: 2013-04-30 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 13:07:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
improved patch (1.95 KB, patch)
2008-01-14 10:39 EST, Adam Tkac
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2008-01-11 16:54:10 EST
mtools-3.9.11-2.fc8.i386.rpm (in F-8 and rawhide) includes
/usr/share/info/dir.gz, which seems like an unintended file for the mtools
package.  Is there a reason for this?
Comment 1 Adam Tkac 2008-01-14 09:18:57 EST
You're right. File wrote above is bogus and is not part of mtools. Fix is
commited in CVS, build will wait for gcc 4.3. I'm not going to fix this minor
problem in F8. Thanks for report
Comment 2 Todd Zullinger 2008-01-14 10:19:16 EST
You don't want to remove the install-info calls from %post and %preun.  Those
are needed to properly install the info files as per:
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-47896da5fb2662d75deefeb9ba75145a398515db

Without them, you'll get rpmlint errors like this:

mtools.i386: E: info-files-without-install-info-postin
/usr/share/info/mtools.info.gz

What's probably better is to remove the dir.gz file that mtools installs in the
buildroot during %install.

While you're poking the spec, there are a few other warnings and errors from
rpmlint that you may be interested in (all easy to clean up :):

$ rpmlint mtools-3.9.11-2.1.fc8.src.rpm 
mtools.src: E: non-utf8-spec-file
/tmp/mtools-3.9.11-2.1.fc8.src.rpm.17885/mtools.spec
mtools.src: E: tag-not-utf8 %changelog
mtools.src: W: invalid-license GPlv2+

$ rpmlint mtools-3.9.11-2.1.fc8.i386.rpm 
mtools.i386: E: info-files-without-install-info-postin
/usr/share/info/mtools.info.gz
mtools.i386: E: info-files-without-install-info-postun
/usr/share/info/mtools.info.gz
mtools.i386: W: file-not-utf8 /usr/share/doc/mtools-3.9.11/Changelog
mtools.i386: E: tag-not-utf8 %changelog
mtools.i386: W: invalid-license GPlv2+

If you're busy and not in any hurry, I'll try to make some time in the next day
or so to patch and test the minor tweaks needed to fix up these warnings.  I
just don't have time this morning for that. :)  (It doesn't seem that mtools
builds properly at all in rawhide at the moment anyway, so there seems to be no
rush.)
Comment 3 Adam Tkac 2008-01-14 10:39:00 EST
Created attachment 291596 [details]
improved patch

Looks I was too hurry with patch :) Improved one is attached. With this patch
things works as expected
Comment 4 Adam Tkac 2008-01-14 10:39:57 EST
Of course, changelog will be changed appropriately. Btw thanks for your attention ;)
Comment 5 Adam Tkac 2008-01-17 13:07:55 EST
Fixed in CVS, closing again

Note You need to log in before you can comment on or make changes to this bug.