Bug 428521 - Possible optimizing in package-description?
Possible optimizing in package-description?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 15:08 EST by Reindl Harald
Modified: 2008-01-15 10:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 10:41:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reindl Harald 2008-01-12 15:08:06 EST
Hi - Is for the follwoing problem a solution on the side of iced-tea possible,
because the apllication runs without troubles, only the rpm-descriptions seems
to say there are dependencie-problems

__

[harry@srv-rhsoft:/scripts]$ sudo package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package LimeWire-free requires j2re >= 1.4.1

__

The application runs and says
LimeWire 4.14.0
Java 1.7.0

If this can fixed in any form with the icedtea-package i think this would help
also some other commerical applications written in java because you cant make
any repo in your network provding applications with unresolved dependencies.

You can get for tests the application from here:
http://www.limewire.com/lang/german/downloadfree.shtml
Comment 1 Lillian Angel 2008-01-14 11:26:41 EST
IcedTea works with Limewire. I am not sure the problem is with IcedTea.

You might need to set JAVA_HOME (or otherwise) before running Limewire.

Closing this bug.
Comment 2 Reindl Harald 2008-01-14 16:32:01 EST
Seems that you did not read my report :-)

I reported that limewire wokrs with icedtea well, but if you do not install jsre
from sun the rpm-database reports missing "j2re"

So my querstion is if it is possible to build the package in a way that says
icedtea provides j2re too. 

In other case you cant put limewire in a local yum-repo and updating all your
machines because yum will stop with "missing dependency"
Comment 3 Lillian Angel 2008-01-15 10:27:47 EST
Sorry, I misunderstood your initial comments. It is not very clear- what icedtea
package do you have installed?

How can I reproduce the problem if limewire is not available through yum?

These are the icedtea packages that I have installed:

$ sudo yum provides /usr/lib/jvm/jre-1.7.0-icedtea/
java-1.7.0-icedtea.i586 : IcedTea Runtime Environment

$ sudo yum provides /usr/lib/jvm/java-1.7.0-icedtea/
java-1.7.0-icedtea-devel.i586 : IcedTea Development Environment
Comment 4 Reindl Harald 2008-01-15 10:35:27 EST
No problem :-)

Simply install LimewireFree.rpm, any icedtea-version, no sun-java and yum-utils
Show to my output below and you will see a missing dependencie becaue Limewire
requests "j2re" and only sun-jre provides this

So my question is if it is possible to change the icedtea-package in a way that
any package who requests "j2re" will get the answer "installed" or resolve this
by installing icedtea

___

[root@nb-rhsoft:~]$ package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package LimeWire-free requires j2re >= 1.4.1
Comment 5 Lillian Angel 2008-01-15 10:41:08 EST
Ah I was able to find the rpm you were having problems with.

This is not an issue with IcedTea, it is an issue with the actual rpm
requirements. They stopped providing rpms for limewire anyways. 

You can get a proper limewire rpm here:
http://www.diffingo.com/downloads/diffingo-repo/f7/limewire-free-4.14.8-1.fc7.noarch.rpm

This thread seemed helpful:
http://forums.fedoraforum.org/archive/index.php/t-150340.html

This still is not an IcedTea bug, but a problem with LimewireFree's spec file.
Closing.
Comment 6 Lillian Angel 2008-01-15 10:43:26 EST
> So my question is if it is possible to change the icedtea-package in a way that
any package who requests "j2re" will get the answer "installed" or resolve this
by installing icedtea

No, unfortunately not. The spec files will have to look for (require) Java in a
more standard fashion.
Comment 7 Reindl Harald 2008-01-15 10:52:33 EST
OK - Thank you for the information especially for the repo with limewire f7/f8

Note You need to log in before you can comment on or make changes to this bug.