Bug 428541 - Bogus Perl provides/requires by gdal leads to broken deps
Bogus Perl provides/requires by gdal leads to broken deps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-12 20:19 EST by Alex Lancaster
Modified: 2008-01-16 04:06 EST (History)
0 users

See Also:
Fixed In Version: gdal-1.5.0-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 04:06:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-01-12 20:19:45 EST
the recent 1.5.0 build of gdal in rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=30927

leads to some bogus Perl requires/dependencies and leads to:

Broken deps for i386
----------------------------------------------------------
        gdal-perl - 1.5.0-1.fc9.i386 requires perl(Geo::GDAL::Const)
 
This may be due to the auto dependency checker not appropriately filtering the
provides deps, in which case they may need to be done manually, see:

http://fedoraproject.org/wiki/Packaging/Perl
Comment 1 Alex Lancaster 2008-01-16 04:06:48 EST
Appears to be fixed in latest build gdal-1.5.0-2.fc9:

http://koji.fedoraproject.org/koji/buildinfo?buildID=31401

closing bug.

Note You need to log in before you can comment on or make changes to this bug.