Bug 428561 - Update pam_mount in Fedora 8
Update pam_mount in Fedora 8
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pam_mount (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
https://sourceforge.net/forum/forum.p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 07:42 EST by Roland Wolters
Modified: 2008-02-22 17:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-13 17:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2008-01-13 07:42:31 EST
Description of problem:
There is a newer version available, version 0.32. Is there any specific reason 
why pam_mount has not been updated?
Comment 1 Till Maas 2008-01-13 08:14:24 EST
(In reply to comment #0)
> Description of problem:
> There is a newer version available, version 0.32. Is there any specific reason 
> why pam_mount has not been updated?

The new version of pam_mount uses a different format for the config file (xml),
therefore an update to pam_mount may break existing installations, e.g. in case
the automatic conversion fails or when there are user specific config files.
Therefore the update should only happen during an update to the next release.
Because then people expect, that they may have to do something manually, when it
is mentioned in the release notes. In Fedora 9 there will be this update for
sure, it is already in rawhide.

Is there a specific feature/bugfix you are missing? Maybe I will backport
something to the current version in Fedora 8, but this is a low priority task
for me.
Comment 2 Roland Wolters 2008-01-13 17:12:46 EST
Thanks for the comment.
I don't have any current needs for any backporting: I just wanted to play 
around with pam_mount for home directory encryption but didn't start when I 
saw the old version.
Comment 3 Till Maas 2008-01-13 17:36:40 EST
(In reply to comment #2)
> Thanks for the comment.
> I don't have any current needs for any backporting: I just wanted to play 
> around with pam_mount for home directory encryption but didn't start when I 
> saw the old version.

This should work without any problems. I only suggest to use luks. :-)
Comment 4 Jima 2008-02-22 12:11:26 EST
There's a valid reason to move to 0.29: cron will actually work with it, unlike
0.18.

I see you updated the spec in CVS to 0.29, but never built it.  What was the
reason?  The move to XML config?  Also, running convert_pam_mount_conf.pl in
%pre doesn't work too well when A) you're not packaging it and B) even if you
did, it wouldn't be available until %post. ;-)

I'll be happy to file a separate bug on the horrific pam_mount/crond interaction
if you'd like.
Comment 5 Till Maas 2008-02-22 17:21:15 EST
Actually I never updated the spec for F8, but in devel before F8 was branched in
CVS. But then there was some freeze for development, which made me not build the
new rpm. In the devel branch, there is a further developed spec, that is also
built for rawhide, so it will be in F9. Do you know which changeset in pam_mount
svn fixed the cron issue? Did pam_mount work with cron at any older version than
0.18?

Note You need to log in before you can comment on or make changes to this bug.